Microsoft Excel

Excel und VBA: Beitrag aus Herbers Excel-Forumsarchiv

Formel umbauen

Betrifft: Formel umbauen
von: HoDo
Geschrieben am: 24.07.2011 00:48:08

Hallo
Nach Stunden bin ich wieder am verzweifeln
Bekomme eine Formel einfach nicht umgebaut
Wer kann mir helfen
Beispiel Datei hier steht in Tabelle 2
http://www.herber.de/bbs/user/75840.xlsx

Gruss
Holger

  

Betrifft: AW: Formel umbauen
von: fcs
Geschrieben am: 24.07.2011 10:26:02

Hallo HoDo,

so schwierig ist der Umbau dann doch nicht.
In der Formel muss du halt einmal die Baulänge des Bogens vom Winkel der Rohrleitung abziehen und mit dem gleichen Formelteil (aber eben für 90°) die Einbauläge des 2. Bogens.

Den "Faktor" für die Länge kannst du übrigens direkt aus dem Winkel der Rohrleitung berechnen (=1/SIN(Winkel_im_Bogenmaß).

Den Schweissspalt in G40 hast du manuell eingegeben. Falls er nur von der Rohrgröße abhängig ist, dann kannst du ihn mit folgender Formel ermitteln:

=SVERWEIS(B40;$B$45:$E$49;4;FALSCH)
Gruß
Franz

Tabelle2

 BCDEFGH
39 Rohr-grösse in DNHöhe h in mmWinkel in GradBogen-baulängeRichtungs-wechselSchweiss-spalt in mmPass-tücklänge
40DN65150060°2,5 D90°31420,05
41      1420,05
42  Faktor1,1547 Alternativ1420,05

Formeln der Tabelle
ZelleFormel
H40{=C40*INDEX($D$52:$D$60;VERGLEICH(D40&E40;$B$52:$B$60&$C$52:$C$60;0))-INDEX($B$52:$I$60;VERGLEICH(D40&E40;$B$52:$B$60&$C$52:$C$60;0); VERGLEICH(B40;$B$51:$I$51;0))-INDEX($B$52:$I$60;VERGLEICH(F40;$B$52:$B$60;0); VERGLEICH(B40;$B$51:$I$51;0))-2*G40}
H41{=C40*INDEX($D$52:$D$60;VERGLEICH(D40&E40;$B$52:$B$60&$C$52:$C$60;0))-INDEX($B$52:$I$60;VERGLEICH(D40&E40;$B$52:$B$60&$C$52:$C$60;0); VERGLEICH(B40;$B$51:$I$51;0))-INDEX($B$52:$I$60;VERGLEICH("90°";$B$52:$B$60;0); VERGLEICH(B40;$B$51:$I$51;0))-2*G40}
E42=RUNDEN(1/SIN(WERT(TEIL(D40;1;2))/180*PI()); 4)
H42{=C40*RUNDEN(1/SIN(WERT(TEIL(D40;1;2))/180*PI()); 4)-INDEX($B$52:$I$60;VERGLEICH(D40&E40;$B$52:$B$60&$C$52:$C$60;0); VERGLEICH(B40;$B$51:$I$51;0))-INDEX($B$52:$I$60;VERGLEICH(F40;$B$52:$B$60;0); VERGLEICH(B40;$B$51:$I$51;0))-2*G40}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: Formel umbauen
von: HoDo
Geschrieben am: 24.07.2011 15:16:34

Hallo fcs
Irgendwie komme ich mit der Formel nicht zurecht
kannst du mir eine Beispiel - Datei senden

Gruss Holger


  

Betrifft: AW: Formel umbauen
von: HoDo
Geschrieben am: 24.07.2011 16:28:28

Hallo fcs
Irgend etwas mache ich mit der Formel falsch
Beispiel - Datei wäre super
Gruss
Holger


  

Betrifft: AW: Formel umbauen
von: fcs
Geschrieben am: 24.07.2011 18:48:11

Hallo Holger,

hier deine Datei mit angepasster Formel.
http://www.herber.de/bbs/user/75849.xlsx

Gruß
Farnz


  

Betrifft: noch eine AlternatiVe
von: Erich G.
Geschrieben am: 24.07.2011 18:57:50

Hallo Holger,
vielleicht interessiert dich das hier auch:

 BCDEFGHIJKL
2Etage mit gegebenem Winkel und Richtungswechsel 90°    
3           
4 Rohrgrösse in DNHöhe hWinkel in GradBogenbau-längeRichtungs-wechselSchweiss-spaltErgebnis    
5DN32150045°1,5 D90°42.093,30    
6DN65150060°2,5 D90°51.416,05    
7           
8           
9 Bogenbaulänge 1,5 DBogenbaulänge 2,5 D
10WinkelDN25DN32DN40DN50DN65DN25DN32DN40DN50DN65
1115°55810131012141823
1230°10131520251925293647
1345°16202431393038455672
1460°222833445542536278101
1590°??0??????7393108135205

Formeln der Tabelle
ZelleFormel
H5=C5*RUNDEN(1/SIN(LINKS(D5;2)*PI()/180); 4) -SVERWEIS(D5;$B$11:$L$15;1+VERGLEICH(B5;$C$10:$G$10;0)+5*(E5="2,5 D"); 0) -SVERWEIS(F5;$B$11:$L$15;1+VERGLEICH(B5;$C$10:$G$10;0)+5*(E5="2,5 D"); 0) -2*G5
H6=C6*RUNDEN(1/SIN(LINKS(D6;2)*PI()/180); 4) -SVERWEIS(D6;$B$11:$L$15;1+VERGLEICH(B6;$C$10:$G$10;0)+5*(E6="2,5 D"); 0) -SVERWEIS(F6;$B$11:$L$15;1+VERGLEICH(B6;$C$10:$G$10;0)+5*(E6="2,5 D"); 0) -2*G6

Und hier die Mappe dazu: http://www.herber.de/bbs/user/75850.xlsx

Noch eine Frage: Gibt es keine Tabellenwerte für 90° und Bogenbaulänge 1,5 D ?

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Danke für die Formel
von: HoDo
Geschrieben am: 24.07.2011 19:53:08

Guten Abend
Ein grosses Dank an alle die mir geholfen haben
Wie macht ihr das nur , mit den Formeln . Hat jemand eine Anleitung zur Formelerstellung

MfG
Holger


  

Betrifft: Danke für deine Rückmeldung, aber ...
von: Erich G.
Geschrieben am: 24.07.2011 19:55:52

Hi,

Noch eine Frage: Gibt es keine Tabellenwerte für 90° und Bogenbaulänge 1,5 D ?

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW:Tabellenwerte
von: HoDo
Geschrieben am: 24.07.2011 20:01:35

Hallo Erich

Tabellenwerte für 90° bei einer Bogenbaulänge 1,5 D

DN 25 = 38
DN 32 = 48
DN 40 = 57
DN 50 = 76
DN 65 = 95

MfG
Holger


  

Betrifft: AW: Danke für die Formel
von: HoDo
Geschrieben am: 24.07.2011 19:55:47

Guten Abend
Ein grosses Dank an alle die mir geholfen haben
Wie macht ihr das nur , mit den Formeln . Hat jemand eine Anleitung zur Formelerstellung

MfG
Holger