Microsoft Excel

Herbers Excel/VBA-Archiv

Probleme mit Sverweis und DB


Betrifft: Probleme mit Sverweis und DB
von: Daniel
Geschrieben am: 08.11.2018 17:30:19

Hallo

ich führe in einer Datei zentral Kundendaten, in einer anderen Datei .xlsm verweise ich mit Sverweis auf die zentrale Datei.

Nun nachdem ich die sverweis Formel eingegeben habe, kann ich durch ändern des Suchbegriffs alle Daten finden.

Wenn ich aber in der zentralen Datei eine Änderung vornehme, findet Sverweis immer weiter nur die alten Werte die ich ja gar nicht mehr habe???
Erst wenn ich die Sverweisformel neu eingebe findet er die Neuen Werte.

Hat jemand eine Idee woran das liegen kann und wie man es lösen könnte?

schon mal Danke zum voraus

Daniel

  

Betrifft: AW: Probleme mit Sverweis und DB
von: Hajo_Zi
Geschrieben am: 08.11.2018 17:37:30

hallo Daniel,

ist die automatische Berechnung aus=

GrußformelHomepage

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.
Die Beiträge werden auch ignoriert, es erfolgt keine Antwort.


  

Betrifft: AW: Probleme mit Sverweis und DB
von: Daniel Furrer
Geschrieben am: 08.11.2018 21:54:35

Hallo

Nein, die automatische Berechnung ist an, das habe ich ziemlich am Anfang geprüft.
Dann würde wohl bei einem Neueintrag einer Formel auch nicht gerechnet, denk ich mal.

Ich habe auch die Formate geprüft usw.

Interessant ist, ich muss die Formel nicht einmal komplett neu eingeben, ich kann mit F2 rein, einen Teil der Formel markieren und dann ohne weitere Änderung mit Enter abschliessen, und schon wird der Neue Wert "gezogen"....


  

Betrifft: AW: Probleme mit Sverweis und DB
von: SF
Geschrieben am: 08.11.2018 22:19:16

Hola,

dann hast du einen Text der wie eine Zahl aussieht.

Gruß,
steve1da


  

Betrifft: AW: Probleme mit Sverweis und DB
von: Daniel Furrer
Geschrieben am: 08.11.2018 22:28:10

Nein die Formate können nicht das Problem sein, weil ja der Suchbegriff, nur durch Wiedereingabe der Sverweis formel plötzlich richtig gefunden wird, dann hat das weder etwas mit der Formel zu tun noch mit den Formaten des Suchbegriffs oder der Matrix wo gesucht wird.

Ich denke es muss etwas damit zu tun haben, wie Excel die Verknüpfung der Tabellen oder Dateien organisiert.
Was läuft ab nach der Eingabe einer Formel die auf eine andere Datei verweist die nicht geöffnet ist.
Und was ist das Entscheidende was fehlt, wenn man nur den Suchbegriff ändert und eben nicht die Formel neu eingibt.


  

Betrifft: AW: Probleme mit Sverweis und DB
von: SF
Geschrieben am: 09.11.2018 08:34:48

Hola,

Nein die Formate können nicht das Problem sein

können sie wohl.
Das ändern des Formats einer Zelle wirkt sich nicht direkt auf den Inhalt aus, sondern erst durch Neueingabe der Daten.
nur durch Wiedereingabe der Sverweis formel plötzlich richtig gefunden wird
Das wäre dann genau der Fall.
Als Profi sollte man das wissen.

Gruß,
steve1da


  

Betrifft: AW: Probleme mit Sverweis und DB
von: Daniel
Geschrieben am: 09.11.2018 08:56:57

Hola Steve

Gracias, aber dann hilf mir doch bitte mal diese Möglichkeit auszuschliessen oder zu korrigieren.

- Die Zelle mit der sverweisformel hat Format Standard
die Formel =SVERWEIS($G$16;'O:\- monatliche Datenextrakte\[Debitoren.xlsx]Debitoren'!$A$6:$L$242;11;FALSCH)
- Die Zelle mit dem Suchbegriff hat auch Format Standard
- Die Zellen in der Matrix nach denen gesucht wird haben auch Format Standard

soweit sieht es ja ok aus, gibt es noch mehr das ich prüfen sollte/könnte ?


  

Betrifft: AW: Probleme mit Sverweis und DB
von: SF
Geschrieben am: 09.11.2018 09:00:23

Hola,

also, das Format einer Zelle sagt nichts über deren Inhalt aus. Standard kann sowohl Zahlen als auch Text enthalten. Prüf mal bitte mit Istzahl() oder Isttext() die Zelle G16 und die entsprechende Zelle in Spalte A vom Blatt "Debitoren". Sind beide Ergebnisse gleich?

Gruß,
steve1da


  

Betrifft: AW: Probleme mit Sverweis und DB
von: Daniel
Geschrieben am: 09.11.2018 09:45:08

Geprüft, in beiden Fällen ist Isttext = Wahr und Istzahl = Falsch Ich Suche nach "GA03" oder "GA05"

Weisst Du was mich zu der Annahme führt, dass es mit der Art der Verknüpfung der Tabellen zu tun haben muss.

Ich kann die Formel in der selben Form neu eingeben, danach funktioniert es einwandfrei und ich kann nach 50 verschiedenen Suchbegriffen die korrekten Resultate finden.

Wenn ich aber die Daten komplett verändere in der Suchtabelle nicht nur einen Datensatz sondern zB alle. Und dann die Datei wieder speichere,
ist das Resultat wie wenn immer noch die alten Daten dort wären! Die Formel funktioniert weiter und findet alles, jedoch wie wenn es gar keine Änderungen gegeben hätte.

Also muss Excel irgendwo im Hintergrund die ganze Tabelle gespeichert haben und die Formel in der Zelle linkt auf diese "Schattentabelle"

Und erst wenn ich die Formel dann neu eingebe, wird die Verlinkung auf eine neue aktuelle "Schattentabelle" erzeugt, aber nur für die Zelle wo ich die Formel ersetzt habe.
Andere Zellen mit Sverweis linken weiter auf die alte Version der Daten, die sichtbar für mich gar nicht mehr existieren.

Ich probierte auch die Funktion "Alle aktualisieren", das hat aber auch nichts gebracht. :-(