Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn dann Formel


Betrifft: Wenn dann Formel
von: Andreas
Geschrieben am: 28.11.2018 12:48:23

Hallo Spezialisten,

bitte um Hilfe, (Datei im Anhang)
ich benötige eine Formel die die Zellen von G3:G12 für 2016 und F3:F12 nur (Zeit)BU zusammenfasst
und dann die Summe aus D3:D12 errechnet.

Ich hoffe das einigermaßen verständlich erklärt zu haben :)

Für eure Mühe vielen Dank im Voraus.
Gruß
Andreas

http://www.herber.de/bbs/user/125721.xlsx

  

Betrifft: AW: Wenn dann Formel
von: PeterK
Geschrieben am: 28.11.2018 13:00:13

Hallo

Z.B


=SUMMEWENNS(D3:D12;G3:G12;"2015";F3:F12;"BU")




  

Betrifft: AW: Wenn dann Formel
von: UweD
Geschrieben am: 28.11.2018 13:10:23

Hallo

so???


Tabelle1

 ABCDEFG
1       
2NrFirmaNameSummeErläuterungZeitHHJ
3300Test 1Montage149000 BU'2016
4300Test 2Montage28163,4 SV'2017
5300Test 3Montage31164,77 SV'2017
6300Test 4Montage41500 SV'2018
7300Test 5Montage55223,89 SV'2016
8300Test 6Montage6100 BU'2015
9300Test 7Montage715000 SV'2017
10300Test 8Montage82058,7 SV'2018
11300Test 9Montage92194,6 BU'2017
12300Test 10Montage104000 SV'2015
13   88405,36   
14       
15       
16 ZeitGesammtsummeNur die Summe 2015Nur die Summe 2016Nur die Summe 2017Nur die Summe 2018
17 BU51294,6100490002194,60
18 SV37110,7640005223,8924328,173558,7
19  88405,36410054223,8926522,773558,7

verwendete Formeln
Zelle Formel Bereich N/A
D13=SUMME(D3: D12)  
C17:C18=SUMMEWENN($F$3:$F$12;$B17;$D$3:$D$12)  
D17:G18=SUMMENPRODUKT(($F$3:$F$12=$B17)*($G$3:$G$12=RECHTS(D$16;4))*($D$3:$D$12))  
C19:G19=SUMME(C17:C18)  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




LG UweD


  

Betrifft: AW: Wenn dann Formel
von: Andreas
Geschrieben am: 28.11.2018 13:22:02

HERZLICHEN DANK AN BEIDE USER, funzt alles !!!!

Grüße
Andreas


  

Betrifft: gern geschehen owT
von: UweD
Geschrieben am: 28.11.2018 13:51:41