Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis > in Matrix ist ein Hyperlink


Betrifft: Sverweis > in Matrix ist ein Hyperlink
von: Werner
Geschrieben am: 03.12.2018 15:24:51

Hallo Excel-Freunde
ich habe folgenden SVerweis
=SVERWEIS(F11;Tabelle3!B10:C64;1;FALSCH)
in der Matrix B10:C64 steht in der ersten Spalte
ein funktionierender Hyperlink (hier abgekürzt)
https://...intranet.c.com/sites/S./_layouts/userdisp.aspx?ID=118
Ich habe den Sverweis wie folgt angepasst
=HYPERLINK(SVERWEIS(F12;Tabelle3!B10:C64;1;FALSCH))
Jedoch kommt der Hinweis
"Datei kann nicht geöffnet werden"

Gibt es eine Möglichkeit, dieses Hyperlink aus der Matrix
via SVerweis an einer anderen Stelle "anklickbar" auszuwerten ?

Freu mich auf einen Tipp
Gruß
Werner

  

Betrifft: AW: Sverweis > in Matrix ist ein Hyperlink
von: Sandra.B
Geschrieben am: 03.12.2018 15:57:13

Hallo Werner,

ich sehe soweit keinen Fehler in Deiner Formel, außer das du Dich einmal auf F11 und beim zweiten mal auf F12 beziehst.

Hast du die Möglichkeit eine Beispieldatei hochzuladen?

LG Sandra


  

Betrifft: AW: Sverweis > in Matrix ist ein Hyperlink
von: Werner
Geschrieben am: 03.12.2018 17:30:38

Hi
ja, Tippfehler hier im Forum w F11

Ein Upload der Datei ist nicht möglich,
da der Hyperlink auf eine interne Sharepoint-Seite zeigt.

Vielleicht muss ich noch einen Hinweis geben:
Der Hyperlink https://...intranet.c.com/sites/S./_layouts/userdisp.aspx?ID=118
ist nicht direkt in der Zelle , sondern
In der Zelle steht
"Standort ABC"
und die Zelle wurde mit einem Hyperlink "hinterlegt"

Idee ?

Gruß
Werner


  

Betrifft: AW: Sverweis > in Matrix ist ein Hyperlink
von: Sandra.B
Geschrieben am: 03.12.2018 18:23:20

Hey ho,

das erklärt es. Somit hat der Link keinen Bezug.
Dann schreib den genauen Pfad in eine Hilfsspalte und wende Deine Formel darauf an. Das sollte das Problem lösen.

LG Sandra