Microsoft Excel

Herbers Excel/VBA-Archiv

Verschiedene Spalten zusammenführen


Betrifft: Verschiedene Spalten zusammenführen
von: LimonZn
Geschrieben am: 04.12.2018 17:36:35

Ich habe folgende Frage zur Spalte H. Wie kann ich hier die Ergebnisse aus Spalte C bis G mit folgenden Prioritäten zusammenführen?

Wenn Leerstelle in Spalte C, nehme Umsatzwert aus dem jeweiligen Transaktionsjahr(Transaktionsjahr ist in Spalte A angegeben). Beispiel für Transaktion aus 2016: Nehme Wert aus Spalte E

Wenn Wert in Spalte C vorhanden, nehme diesen Wert

In Zelle H4 habe ich versucht die passende Formel hierfür zu formulieren, klappt aber leider nicht. In Spalte J wird gezeigt, wie das Ergebnis aussehen sollte. Welche Formel kann man für dieses Vorhaben verwenden?

http://www.herber.de/bbs/user/125882.xlsx

  

Betrifft: AW: Verschiedene Spalten zusammenführen
von: Sepp
Geschrieben am: 04.12.2018 21:08:36

Hallo ?,

Tabelle1

 ABCDEFGH
3TransaktionsdatumCompanyUmsatz (letzte 12 Monate vor Transaktionsdatum)Umsatz 2015Umsatz 2016Umsatz 2017Umsatz 2018Umsatz im Transaktionsjahr
411.22.2018A400-200250-400
507.10.2018B----140140
606.28.2018C200 140180210200
709.26.2017D------
804.10.2017E--100130150130
904.05.2017F300110270305380300
1003.31.2017G---120-120
1112.23.2016H10040110--100
1210.25.2016I200----200
1308.11.2016J------
1411.24.2015K-100110140180100
1510.19.2015L250----250
1606.24.2015M-70-14010070

Formeln der Tabelle
ZelleFormel
H4=WENN(ISTZAHL(C4); C4;INDEX(D4:G4;;VERGLEICH(JAHR(A4); $D$2:$G$2;0)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8




 ABCDEF
1Gruß Sepp
2
3