Microsoft Excel

Herbers Excel/VBA-Archiv

Eingabe in eine Zelle vergleichen mit Werten


Betrifft: Eingabe in eine Zelle vergleichen mit Werten
von: Peter Schlafmann
Geschrieben am: 06.12.2018 18:52:15

Hallo, ich habe ein Excel Sheet mit Artikel Stammdaten in 3 Spalten und mehreren Zeilen

Artikel Beschreibung Preis

abc 123 23,30

def 456 15,90

ghi 789 25,80

In einem 2.ten Excel Sheet will ich Angebote schreiben - in einer Zelle den Wert Artikel eintippen ( also abc oder def oder ghi) und dann soll Excel aus Sheet 1 die 3 passenden Zeilen kopeiren und in Sheet 2 einfügen.

Geht so was mit VBA oder mit Excel Formeln? oder gibt es einen sinnvolleren Weg.

Danke vorab

  

Betrifft: Formel SVERWEIS() owT.
von: ChrisL
Geschrieben am: 06.12.2018 18:57:30

.


  

Betrifft: AW: Eingabe in eine Zelle vergleichen mit Werten
von: Torsten
Geschrieben am: 07.12.2018 07:48:25

Hallo Peter,

ich versteh nicht ganz. Welche

3 passenden Zeilen kopeiren und in Sheet 2 einfügen
???

Du hast in deinem Beispiel pro Artikel nur eine Zeile. Meinst du vielleicht Spalten?

Ich glaube es ist besser, wenn du mal ne Beispieldatei hochlaedst mit Ausgangssituation und Wunschergebnis.

Gruss Torsten


  

Betrifft: SVerweis? owT
von: Bernd
Geschrieben am: 07.12.2018 07:51:00




  

Betrifft: AW: SVerweis? owT
von: Torsten
Geschrieben am: 07.12.2018 07:56:54

SVERWEIS gibt aber nur einen Zellwert zurueck. Er moechte aber mehrere Zellen kopieren!!!


  

Betrifft: AW: Eingabe in eine Zelle vergleichen mit Werten
von: SF
Geschrieben am: 07.12.2018 09:11:23

Hola,

http://excelformeln.de/formeln.html?welcher=28

Geraten weil deine Beschreibung sehr wenig aussagt.

Gruß
steve1da


  

Betrifft: Du meinst die passenden Zellen - nicht Zeilen
von: WF
Geschrieben am: 07.12.2018 11:26:25

=SVERWEIS($A1;Tabelle1!$A:$C;SPALTE(B1))
und eins nach rechts kopieren

WF