Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrere Werte in einer Zelle und Array


Betrifft: Mehrere Werte in einer Zelle und Array
von: Max Gehweiler
Geschrieben am: 06.12.2018 21:57:36

Hallo zusammen,

ich habe die Anforderung, dass ich aus einer Liste von Werten die unterschiedlich aufgelistet sind:
z.B. 100+200 oder 100/200 oder 100+(200/300)
Korrelationen zwischen den Werten auswerten möchte.

Dh. ich habe eine 1vs1 Matrix für alle Werte und möchte nun die Liste nach Zellwerten durchsuchen, in denen beide Werte der Matrix in einer Zelle vorkommen. Falls die Kombination in einer Zelle gefunden wird, soll eine WAHR zurückgegeben werden.

Gibt es dazu eine passende Verformelung?

Vielen Dank im Vorraus.

  

Betrifft: AW: Mehrere Werte in einer Zelle und Array
von: {Boris}
Geschrieben am: 06.12.2018 22:20:27

Hi Max,

eine Beispieldatei MIT Deinen Wunschergebnissen würde hier sicher Wunder wirken.

VG, Boris


  

Betrifft: AW: Mehrere Werte in einer Zelle und Array
von: Max
Geschrieben am: 06.12.2018 22:27:11

Hier die Datei:

http://www.herber.de/bbs/user/125949.xlsx


  

Betrifft: Kombis finden und mit x markieren
von: WF
Geschrieben am: 06.12.2018 23:03:45

Hi,

in G4:
=WENN(G$3=$F4;"";WENN(SUMMENPRODUKT(ISTZAHL(FINDEN(G$3;$B$4:$B$10))*ISTZAHL(FINDEN($F4;$B$4:$B$10))); "x";""))
nach rechts und nach unten kopieren

Salut WF