Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen wenn X in Spalte (aber nur jede Dritte)


Betrifft: Zählen wenn X in Spalte (aber nur jede Dritte)
von: Hannes
Geschrieben am: 10.12.2018 09:44:45

Hallo Expertenteam!

Ich würde gerne Kundendaten auswerten und müsste hierzu zählen, wie häufig ein X in Spalten gesetzt ist. Mein Problem dabei ist, dass jeder Kunde drei Spalten mit unterschiedlichen Ankreuzmöglichkeiten hat und ich somit nicht einfach zählenwenn über die Zeile anwenden kann.

Die Formel müsste im Grunde immer nur jede dritte Spalte mit einbeziehen. Kann man das einfach lösen?

Hannes

  

Betrifft: AW: Zählen wenn X in Spalte (aber nur jede Dritte)
von: Buddy
Geschrieben am: 10.12.2018 10:01:08

Hallo Hannes,

Du könntest z.B. eine Hilfsspalte anlegen, die 3 Einträge jeweils durchzählen und dann mit

Summenprodukt((A1:A50 ="X")*(B1:B50 =3))

zu x zählen, die jeweils in der 3. Zelle des jeweiligen Kunden stehen.

Gruß
Buddy


  

Betrifft: x in jeder 3. Spalte zählen / also in A1-D1-G1-
von: WF
Geschrieben am: 10.12.2018 10:59:10

Hi,

folgende Arrayformel:
{=SUMME((WENN(REST(SPALTE(A1:Z1);3)=1;A1:Z1)="x")*1)}

Salut WF


  

Betrifft: AW: x in jeder 3. Spalte zählen / also in A1-D1-G1-
von: Hannes
Geschrieben am: 10.12.2018 13:18:02

Irgendwie mache ich einen Denkfehler dabei - wo liegt mein Fehler?

http://www.herber.de/bbs/user/125995.xlsx


  

Betrifft: AW: x in jeder 3. Spalte zählen / also in A1-D1-G1-
von: Daniel
Geschrieben am: 10.12.2018 13:23:16

Hi

probiers mal so, Formel für U4, kann nach rechts und nach unten gezogen werden:

=ZÄHLENWENNS($B$3:$S$3;U$3;$B4:$S4;"X")

Gruß Daniel


  

Betrifft: AW: x in jeder 3. Spalte zählen / also in A1-D1-G1-
von: Daniel
Geschrieben am: 10.12.2018 13:23:17

Hi

probiers mal so, Formel für U4, kann nach rechts und nach unten gezogen werden:

=ZÄHLENWENNS($B$3:$S$3;U$3;$B4:$S4;"X")

Gruß Daniel


  

Betrifft: AW: x in jeder 3. Spalte zählen / also in A1-D1-G1-
von: Hannes
Geschrieben am: 10.12.2018 13:29:41

Top. Das hilft mir weiter. Danke!


  

Betrifft: Du fängst nicht in Spalte A sondern B an
von: WF
Geschrieben am: 10.12.2018 13:33:07

Hi,

Spalte(A) =1 dividiert durch 3 bleibt ein Rest von 1
Spalte(B) =2 dividiert durch 3 bleibt ein Rest von 2

die 3 Formeln in U4, V4, W4 lauten:
{=SUMME((WENN(REST(SPALTE(B4:S4);3)=2;B4:S4)="x")*1)}
{=SUMME((WENN(REST(SPALTE(B4:S4);3)=0;B4:S4)="x")*1)}
{=SUMME((WENN(REST(SPALTE(B4:S4);3)=1;B4:S4)="x")*1)}

WF