Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert mit 2 Funktionen


Betrifft: Mittelwert mit 2 Funktionen
von: Patrick
Geschrieben am: 10.12.2018 10:57:07

Guten Morgen ich hätte folgendes Problem und würde mich über eine Lösung freuen.
In Zelle B5+C5+D5+E5 stehen jeweils Zahlen.
Davon soll der Mittelwert in Zelle F5 gebildet werden.
Zelle B5+D5 soll allerdings immer mal 2 gerechnet werden.
Sind die Zellen leer soll nichts passieren auch keine 0 darin stehen da sonst der Mittelwert falsch wäre.

Ich hoffe ihr könnt mir weiter helfen :)

Viele Grüße

  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Daniel
Geschrieben am: 10.12.2018 11:09:32

Hi

wenn B5 und D5 doppelt gewichtet werden sollen dann so:

=Summe(B5:E5;B5;D5)/Anzahl(B5:E5;B5;D5)

Gruß Daniel


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Patrick
Geschrieben am: 10.12.2018 11:32:09

Hi,

funktioniert leider beides nicht. Summe bräuchte ich nicht sondern Mittelwert.
und bei der 2 Antwort habe ich das Problem wenn die Zelle leer ist, Rechnet er trotzdem das *2 mit rein :/


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Daniel
Geschrieben am: 10.12.2018 11:36:00

HI

da hat wohl jemand in der Schule nicht aufgepasst, oder ist nicht in der Lage, eine Formel die länger als 20 Zeichen ist, zu lesen!

Der Mittelwert ist definiert als SUMME der Werte geteilt durch die ANZAHL der Werte

Gruß Daniel


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Patrick
Geschrieben am: 10.12.2018 12:27:32

Hi,

ja aber inwiefern hilft mir das wenn der Wert aus Zelle B5+D5 doppelt gerechnet werden soll ? :)


  

Betrifft: AW: Schau dir doch mal meine Formel an!!! owt
von: Herbert Grom
Geschrieben am: 10.12.2018 12:28:54

,,,


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Daniel
Geschrieben am: 10.12.2018 13:19:42

Hi
naja das wird er doch, weil diese Werte 2x in die Berechnung eingehen, sowohl bei der Summe, als auch bei der Berechnung der Anzahl der Werte.
zumindest ist das bei mir in Excel 2016 so, dh wenn ich den Zellbereich B5:E5;B5;D5 eingebe, werden die Zellen B5 und D5 zwei mal berücksichtigt, dh jeder mit ";" abgetrennte Zellbereich wird auch einzeln berücksichtigt, es findet keine Überprüfung statt, ob es eine Überschneidung mit den anderen Zellbereichen gibt.
Könnte natürlich sein, dass ein Excel365 da anders arbeitet, aber das kann ich nicht beurteilen.

Gruß Daniel


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Herbert Grom
Geschrieben am: 10.12.2018 13:36:39

Hallo Daniel,

bei der Multiplikation mit 2 mag das ja noch gehen, aber wenn es mal sein müsste, dass er die Zahlen in B und D mal 4 oder mehr nehmen muss, ist meine Version die eindeutig handlichere, zumal dann ja auch noch der Abschnitt "/ANZAHL(1/B5:E5)" entfällt!

Servus


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Daniel
Geschrieben am: 10.12.2018 13:57:14

Hi
naja, deine Version funktioniert nicht, weil sie nur bei der Summe die Zellen unterschiedlich gewichtet, aber nicht bei der Anzahl
Das ergibt dann, wenn in allen Zellen die 1 steht, nicht 1 als Mittelwert, sondern 1,5!
ich glaube kaum, dass das gewünscht ist.
Für einen Mittelwert mit unterschiedlichen Gewichtungen musst du nicht nur bei der Summe die Gewichtung einbringen, sondern auch bei der Anzahl und das macht deine Formel nicht.
außerdem hat die direkte Multiplikation der Werte den Effekt, dass Leerzellen keine Leerzellen mehr sind die ignoriert werden, sondern als Wert 0 ganz normal in die Mittelwertsberechnung mit eingeben.

bei einem anderen Wichtungsfaktor als 2 könnte man meine Formel so abändern, um dann auch andere Wichtugnsfaktoren einfach einfügen zu können:

=(Summe(B5;D5)*2+Summe(C5;E5)) / (Anzahl(B5;D5)*2+Anzahl(C5;E5))
Gruß Daniel


  

Betrifft: AW: Mittelwert mit 2 Funktionen
von: Herbert Grom
Geschrieben am: 10.12.2018 15:04:25

Hallo Daniel,

da hast du auch wieder recht! Da habe ich nicht zu Ende gedacht!

Servus


  

Betrifft: AW: =MITTELWERT(B5*2;C5;D5*2;E5) owt
von: Herbert Grom
Geschrieben am: 10.12.2018 11:18:01

,,


  

Betrifft: AW: =SUMME(B5:E5;B5;D5)/ANZAHL(1/B5:E5) owT
von: Josef B
Geschrieben am: 10.12.2018 11:59:37

Gruss Seppp