Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis mal anders


Betrifft: sverweis mal anders
von: Thomas
Geschrieben am: 20.12.2018 12:39:45

Hallo Excelfreunde,

ich versuche gerade einen Sverweis zusammenzubauen.

mit SVERWEIS($A1;INDIREKT($J1&"4:"&$K1&"8");J$3;0) ist es auch gelungen.

und es funktioniert auch schon ganz gut. Das Problem ist meine wirklichen Daten ( Matrix ) stehen nicht in der Tabelle " tageweise" sondern in der Tabelle "Temp".

Das Ergebnis muss aber in der Tabelle " tageweise" bleiben.

Kann mir jemand dabei helfen?

In der Beispieltabelle habe ich es ein wenig besser beschrieben

besten dank schon mal für euer Interesse.

mfg Thomas
http://www.herber.de/bbs/user/126231.xlsx

  

Betrifft: auch die Datei...
von: Rudi Maintaire
Geschrieben am: 20.12.2018 12:50:20

... hilft nicht wirklich weiter.
Keine Daten in Temp.
Erstelle eine Datei, die der Realität entspricht.

Mir ist schleierhaft, was du willst.

Gruß
Rudi


  

Betrifft: sverweis mal anders
von: Thomas
Geschrieben am: 20.12.2018 13:11:46

Hallo Rudi,


cool das du dir dies mal anschaust. Ich benötige das Ergebnis von Zelle J8 und K8 Tabelle " tageweise".Dies muss auch da bleiben. Der Suchwert ( vom Sverweis steht in A1) steht in Zelle A1. Das Problem ist ich schaffe es nicht die Matrix aus dem Blatt " tageweise" zu verschieben dann funktioniert der sverweis aus Zelle J8 nicht mehr.

Der Hintergrund ist: Ich bekomme die Daten aus der Tabelle " Temp" aus einem anderen Programm. Das Problem ist die Spalten sind nicht immer an der gleichen stelle. Mal ist eine Spalte mehr und mal weniger. Deshalb benötige ich ein Sverweis der sich die Spalte " Personal" sucht, Diese Spalte ist dann der Anfang der Matrix.
Im Blatt " tageweise" kann man die Überschriftenzeile ( Zeile 4 ) Spaltenweise verschieben und der Sverweis funktioniert trotzdem. Jedoch nur solange die Matrix in der Tabelle " tageweise" ist.



http://www.herber.de/bbs/user/126232.xlsx


MFG Thomas


  

Betrifft: AW: sverweis mal anders
von: Rudi Maintaire
Geschrieben am: 20.12.2018 13:26:56

Hallo,
in Temp die Überschriften in Zeile 4:
=SVERWEIS($A$1;INDEX(temp!$4:$20;;VERGLEICH("personal";temp!$4:$4;)):INDEX(temp!$4:$20;; VERGLEICH("personal";temp!$4:$4;)+2);2;)

Gruß
Rudi


  

Betrifft: COOOOl besten dank an Rudi
von: Thomas
Geschrieben am: 20.12.2018 13:51:49

Hallo Rudi,

man du bist ein Pfundskerl. Besten dank da baue ich schon seid zwei Tagen dran.

Riesen Dank.


MFG Thomas