Microsoft Excel

Herbers Excel/VBA-Archiv

Wieviele Montage


Betrifft: Wieviele Montage
von: Chris
Geschrieben am: 05.01.2019 10:58:32

Hallo,

mal eine kurze Frage,

gibt es eine Formel, die wenn ich in A1 eine Jahreszahl schreibe, mir sagt wieviele Montage es in diesem Jahr gab?

Danke
Chris

  

Betrifft: Anzahl Montage p.a.
von: WF
Geschrieben am: 05.01.2019 11:08:02

Hi,

Jahreszahl in A1
=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT(DATUM(A1;1;1)&":"&DATUM(A1;12;31)));2)=1)*1)

WF

siehe unsere:
http://excelformeln.de/formeln.html?welcher=251


  

Betrifft: AW: Anzahl Montage p.a.
von: Chris
Geschrieben am: 05.01.2019 11:41:59

Hallo WF,

danke erstmal. Irgendwie klappt damit was nicht, ich hab testweise das Jahr 1988 genommen weil da der 29.2. auf einen Montag fiel. Entweder ich hab mich beim Nachzählen im Kalender vertan oder in diesem Spezialfall rechnet die Formel nicht richtig. Ich denke aber mal ich hab mich verzählt.

Gruß
Chris


  

Betrifft: Schaltjahre sind wurscht
von: WF
Geschrieben am: 05.01.2019 12:03:50

1988 hat 52 Montage


  

Betrifft: AW: Schaltjahre sind wurscht
von: Chris
Geschrieben am: 05.01.2019 12:23:11

dann hab ich mich wohl verzählt sorry


  

Betrifft: Genau, ein Jahr hat immer 52 Montage, ...
von: Luc:-?
Geschrieben am: 05.01.2019 12:22:20

…Chris,
es sei denn, es beginnt oder endet mit einem Montag, was alle 5-6 Jahre der Fall ist. Von den Schaltjahren ist dann auch nur der Abstand der Jahre mit 53 Montagen abhängig.
Gruß, Luc :-?


  

Betrifft: Was mich natürlich auf die Idee bringt, …
von: RPP63
Geschrieben am: 05.01.2019 12:48:45

… die Formel von Excelformeln erheblich zu verschlanken und das "ungeliebte" INDIREKT() zu verhindern, Luc!
(mal sehen, was WF davon hält)

 ABC
120005252
220015353
320025252
420035252
520045252
620055252
720065252
820075353
920085252
1020095252
1120105252
1220115252
1320125353
1420135252
1520145252
1620155252
1720165252
1820175252
1920185353
2020195252
2120205252
2220215252
2320225252
2420235252
2520245353
2620255252

ZelleFormel
B1=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT(DATUM(A1;1;1)&":"&DATUM(A1;12;31)));2)=1)*1)
C1=52+ODER(REST(DATUM(A1;1;1);7)=2;REST(DATUM(A1;12;31);7)=2)


Gruß Ralf


  

Betrifft: da steht bei uns noch kürzeres ohne INDIREK
von: WF
Geschrieben am: 05.01.2019 12:56:58

http://excelformeln.de/formeln.html?welcher=251


  

Betrifft: ...aber wohl idR allgemeiner u.doch speziell ...
von: Luc:-?
Geschrieben am: 05.01.2019 13:25:27

…(Eindruck nach Überfliegen) und nicht 52-basiert, Walter.
Dir noch ein Gutes Neues! Gruß, Luc :-?


  

Betrifft: Gute Idee, …
von: Luc:-?
Geschrieben am: 05.01.2019 13:01:20

…Ralf,
Ergebnisse stimmen von 1986 bis 2025 überein und sicher auch darüber hinaus. Möglicherweise kann man auch eine einigermaßen regelmäßige mathematische Zahlenfolge der Abstände daraus ableiten, die dann nur noch ein Startjahr benötigt.
Gruß, Luc :-?


  

Betrifft: AW: Wieviele Montage
von: Günther
Geschrieben am: 05.01.2019 13:38:35

Moin,
na gut, dann gebe ich auch noch meinen Senf aus der PQ-Tube dazu ;-)
Ich habe es mal von 1950 bis 2018 berechnen lassen und bin zu diesem Ergebnis gekommen, wobei ich die 52er-Wochen gefiltert habe:

Jahr	Anzahl
1951	53
1956	53
1962	53
1968	53
1973	53
1979	53
1984	53
1990	53
1996	53
2001	53
2007	53
2012	53
2018	53
Gruß
Günther


  

Betrifft: AW: Wieviele Montage
von: onur
Geschrieben am: 05.01.2019 16:12:02

Noch eine Version:

=52+(WOCHENTAG(DATUM(A1;1;1);1)+(REST(A1;4)=0)=2)



  

Betrifft: Fast OK, ...
von: Luc:-?
Geschrieben am: 05.01.2019 16:35:27

…Onur;
deine Fml liefert für 1996, anders als WFs und Ralfs, nur 52. Silvester fiel damals auf einen Dienstag.
Gruß, Luc :-?


  

Betrifft: AW: Wieviele Montage
von: onur
Geschrieben am: 05.01.2019 16:28:23

Noch ein bisschen kürzer:

=52+(REST(DATUM(A1;1;1);7)+(REST(A1;4)=0)=2)



  

Betrifft: Gleiches Ergebnis wie oben! owT
von: Luc:-?
Geschrieben am: 05.01.2019 16:38:03

:-?


  

Betrifft: AW: Gleiches Ergebnis wie oben! owT
von: onur
Geschrieben am: 05.01.2019 17:57:58

Sorry, hatte wie im Beispiel erst ab 2000 getestet.

=52+(WOCHENTAG(DATUM(A1;1;1);12)+(REST(A1;4)=0)>6)

oder
=52+(REST(DATUM(A1;1;1)+4;7)+(REST(A1;4)=0)>5)



  

Betrifft: Jetzt ist's wohl OK! ;-) owT
von: Luc:-?
Geschrieben am: 06.01.2019 00:42:09

:-?