Microsoft Excel

Herbers Excel/VBA-Archiv

Zahlen von 1 - 3 finden und mit WVERWEIS auslesen


Betrifft: Zahlen von 1 - 3 finden und mit WVERWEIS auslesen
von: erichm
Geschrieben am: 14.04.2019 10:39:25

Hallo,

ich habe 2 Tabellen:

Tabelle Aufteilung: dort befinden sich in Spalte A Textkombinationen, die immer pro Zeile aus 3 Teilen bestehen. Diese Teile werden in ihre Einzelbestandteile getrennt (Spalten E bis AQ); diese Trennung habe ich mit Hilfe des Forums hier bereits gelöst.

Tabelle Fixierung: in dieser Tabelle sollen in den Spalten A bis C die aufgeteilten Textteile der Spalten E bis AQ aus Tabelle Aufteilung eingetragen werden.
Diese Fixierung ist mir bisher insofern gelungen, wenn der erste Wert der Tabelle Aufteilung dort in Spalte E steht. Sobald der 1. Wert aber in Spalte F, G, usw. beginnt, fehlt mir der richtige Lösungsansatz.

Anbei die Musterdatei:
http://www.herber.de/bbs/user/129137.xlsx

Besten Dank für eine Hilfe.

mfg

  

Betrifft: AW: "0" anstelle "3"
von: Fennek
Geschrieben am: 14.04.2019 11:12:01

Hallo,

z.B. steht in Q12 eine "0" anstelle der notwendige "3", ebenso stehen in Range("E12:F34") "0" anstelle "1" oder "2".

In jedem erscheint dieser Ansatz als viel zu umständlich.

mfg


  

Betrifft: Lösung gefunden
von: erichm
Geschrieben am: 14.04.2019 12:22:45

Hallo Fennek,

stimmt, ist insgesamt vielleicht etwas umständlich; aber habe jetzt die Lösung:

In F2 und nach rechts und unten kopieren:
=WENN(UND(MAX($E2:E2)=0;Aufteilung!F2<>"");1;WENN(UND(MAX($E2:E2)=1;Aufteilung!F2<>"");2; WENN(UND(MAX($E2:E2)=2;Aufteilung!F2<>"");3;0)))

mfg


  

Betrifft: AW: INDEX() und VERGLEICH() sowie ZÄHLENWENN() ...
von: neopa C
Geschrieben am: 14.04.2019 12:43:46

Hallo Erich,

... wie Du es bisher dargelegt hast, zunächst eine Vereinfachung Deiner Worttrennung in "Aufteilung" mit einer Formel in E2:
=WENN(ZÄHLENWENN($A2;"*"&E$1&"*");E$1;"") und diese Formel nach rechts und unten ziehend kopieren.

Und in Fixierung zwei Formeln:

In E2: =((INDEX(Aufteilung!$E2:$AQ2;)=E$1)+0>0)*MAX($D2:D2)+(INDEX(Aufteilung!$E2:$AQ2;)=E$1)+0

und diese Formel nach rechts und unten ziehend kopieren.

In A2: =WENNFEHLER(INDEX($1:$1;4+VERGLEICH(SPALTE(A1);$E2:$AQ2;0));"")

und diese Formel nach rechts bis Spalte C und unten ziehend kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: oder nur 1ne! Formel ohne Hilfstabellen, ...
von: neopa C
Geschrieben am: 14.04.2019 13:02:15

Hallo Erich,

... wenn Dein angestrebtes Ergebnis lediglich die Aufteilung mit dem Ergebnis wie in Fixierung!A2:C### sein sollte, dann kannst Du Dir auch alle Deine zig Hilfsspalten ganz sparen.

Dann reicht in Fixierung!A2 folgende Matrixfunktion(alität)sformel die keines spez. Formelabschluss wie eine klassische Matrixformel benötigt.

=INDEX($1:$1;AGGREGAT(15;6;SPALTE($E2:AQ$12)/VERGLEICH("*"&$E$1:$AQ$1&"*";Aufteilung!$A2;0)^0;SPALTE(A2)))

und diese nach Spalte C und weit genug nach unten ziehend kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: bei Bedarf noch mit WENNFEHLER() klammern owT
von: neopa C
Geschrieben am: 14.04.2019 13:09:31

Gruß Werner
.. , - ...


  

Betrifft: wieder eine geniale Lösung - vielen Dank! mfg owT
von: erichm
Geschrieben am: 15.04.2019 18:36:56

...