Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Bezug auf Arbeitsblatt


Betrifft: Formel Bezug auf Arbeitsblatt
von: Michael K.
Geschrieben am: 15.04.2019 20:03:12

Hallo und guten Abend,
die größten Problem sind gelöst, jetzt kommt das Feintuning.

Folgende Formel:

=SUMMEWENN(Tabelle2[Spalte4];C10;Tabelle2[Umlage])+N17

Jetzt möchte ich, anstatt Tabelle2 (findet sich im Arbeitsblatt mit dem Namen 2019) in der Formel, die Formel abhängig von einem Eintag in Zelle X1 machen.

Trage ich also in Zelle X1 den Namen des Tabellenblattes ein, soll die Formel in der Tabelle des entsprechnden Tabellenblattes summieren.

Wie könnte die Lösung aussehen=

  

Betrifft: AW: Formel Bezug auf Arbeitsblatt
von: Hajo_Zi
Geschrieben am: 15.04.2019 20:15:18

=
Tabelle1

 CD
13Tabelle 219.01.2019

verwendete Formeln
Zelle Formel Bereich N/A
D13=INDIREKT("'" &C13& "'!C4")  

Zahlenformate
Zelle Format Inhalt
D13 'TT.MM.JJJJ  43484
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.15 einschl. 64 Bit



GrußformelHomepage

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.
Die Beiträge werden auch ignoriert, es erfolgt keine Antwort.


  

Betrifft: AW: Formel Bezug auf Arbeitsblatt
von: Michael K.
Geschrieben am: 15.04.2019 21:10:12

Hallo HaJo,
verstehe ich nicht.


  

Betrifft: AW: Formel Bezug auf Arbeitsblatt
von: Luschi
Geschrieben am: 16.04.2019 04:36:22

Hallo Michael,

hättest Du eine kleine Demodatei bereitgestellt, dann hätte ich Dir Hajos allgemeinen Lösungsvorschlag praktikabel umgesetzt; so aber nur ein paar Infos dazu:
- variable Bezüge auf Tabellennamen bzw. Zellen in einer Formel
- müssen als String (Textkettete) zusammengesetzt werden (per &)
- und mittels INDIREKT()-Funktion in einen realen Bezug umgewandelt werden
- mit dem Excel dann auch was anfangen kann
- und genau zeigt Hajos Vorschlag als Teilvorschlag
- da Tabellennamen auch Leerzeichen enthalten können (leider!)
- spielt das einfache Hochkomma ' noch eine wichtige Rolle dabei

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: Formel Bezug auf Arbeitsblatt
von: Michael K.
Geschrieben am: 16.04.2019 09:50:27

Hallo Hajo, hallo Luschi,
unter folgendem Link findet ihr eine Beispieldatei.

http://www.herber.de/bbs/user/129177.xlsm

Ich habe jetzt alles mögliche probiert, bekomme aber nur Fehlermeldungen und habe mittlerweile die Nerven verloren...……..

Wär schön wenn mir jemand die Formel entsprechend der Beschreibung in der Datei umschreiben könnte.

Viele Grüße
Michael


  

Betrifft: AW: Formel Bezug auf Arbeitsblatt
von: SF
Geschrieben am: 16.04.2019 11:05:57

Hola,

=SUMMEWENN(INDIREKT("'"&B4&"'!B4:B10");C4;INDIREKT("'"&B4&"'!C4:C10"))
Gruß,
steve1da


  

Betrifft: AW: Formel Bezug auf Arbeitsblatt
von: Michael K.
Geschrieben am: 16.04.2019 17:29:37

Hallo steve1a,

vielen, vielen Dank!

Klappt jetzt einwandfrei.


Viele Grüße
Michael


  

Betrifft: und warum dann offen? o.w.T.
von: Werner
Geschrieben am: 17.04.2019 17:34:37