Microsoft Excel

Excel und VBA: Formeln, Programmierung, Lösungen

Die Excel/VBA-Beispiele

Thema

Formelbereich in Einzelelemente aufschlüsseln

Gruppe

Zeichenfolge

Problem

Wie kann ich eine Formel wie =SUMME(A1:A3) in ihre Einzelelemente, also =SUMME(A1+A2+A3) aufschlüsseln?

Lösung
Geben Sie die nachfolgende benutzerdefinierte Funktion in ein Standardmodul ein.

StandardModule: basMain

Function FormelText(rng As Range) As String
   Dim rngAct As Range
   Dim sTxt As String, sPre As String
   sTxt = rng.Formula
   sPre = Left(sTxt, InStr(sTxt, "("))
   Set rng = Range(Mid(sTxt, InStr(sTxt, "(") + 1, Len(sTxt) - InStr(sTxt, "(") - 1))
   sTxt = ""
   For Each rngAct In rng.Cells
      sTxt = sTxt & rngAct.Address(False, False) & "+"
   Next rngAct
   FormelText = sPre & Left(sTxt, Len(sTxt) - 1) & ")"
End Function