Microsoft Excel

Excel und VBA: Formeln, Programmierung, Lösungen

Die Excel/VBA-Beispiele

Thema

Summe bilden, wenn Kriterium Zeichenfolge

Gruppe

SUMMEWENN

Problem

Ich habe eine Tabelle mit den Spalten Artikel und Anzahl. Ist es möglich, die Summe der Anzahl jener Artikel zu berechnen, die ein bestimmtes Wort enthalten?

Lösung
Ja, mit der EXCEL-Funktion "SUMMEWENN()". Wenn in A1:A100 die Artikel stehen und in B1:B100 die Anzahl steht, lautet die Formel für die Summe der Artikel "Hosen": =SUMMEWENN(A1:A100;"Hosen";B1:B100). Wildcards sind erlaubt.