Microsoft Excel

Excel und VBA: Formeln, Programmierung, Lösungen

Die Excel/VBA-Beispiele

Thema

Zeiten summieren

Gruppe

TEXT

Problem

In Spalte A werden Zeiten im Sekunden mit Nachkommastellen eingetragen. In Zelle F2 wird die Summe dieser Zeiten in das Format M:SS,00 umgewandelt.

Lösung
Zelle B2: =SUMME(A:A), Zelle C2: =GANZZAHL(B2/60), Zelle D2: =GANZZAHL(B2-GANZZAHL(B2/60)*60), Zelle E2: =(B2-GANZZAHL(B2))*100, Zelle F2: =C2&":"&TEXT(D2;"00")&","&TEXT(E2;"00")