Microsoft Excel

Excel und VBA: Formeln, Programmierung, Lösungen

Download Übungsmappe

Analyse von Aktienwerten mit der WENN-Funktion

Excel ermöglicht Ihnen eine schnelle Entscheidung beim Aktienhandel. Hierzu müssen Sie lediglich die von Ihnen bevorzugten Aktien in eine Liste schreiben. Danach fehlen Excel noch die Angaben, wann Aktien gekauft oder verkauft werden sollen. Eine fertige Liste könnte dann so aussehen:

Abbildung - Aktientabelle
Aktientabelle

Jetzt soll Excel Ihnen immer anzeigen, wann Sie eine Aktie kaufen sollen oder wann sie abgestoßen werden soll. Hierzu ist in Excel eine WENN-Funktion eingebaut, die Ihnen die Möglichkeit gibt, Ihre Zahlen zu analysieren und bei einem bestimmten Ergebnis eine bestimmte Meldung anzuzeigen.

Der nachfolgende Hilfetext von Excel gibt Aufschluß darüber, wie diese Funktion zu schreiben ist. WENN

Liefert von zwei möglichen Werten den Wert, der dem jeweiligen Ergebnis von Prüfung (WAHR oder FALSCH) zugeordnet ist.

Es gibt zwei Formen der Funktion WENN. Die erste Form (Syntax 1) kann sowohl in Tabellen als auch in Makrovorlagen verwendet werden. Die zweite Form (Syntax 2) kann nur in Makrovorlagen zusammen mit den Funktionen SONST, SONST.WENN und ENDE.WENN eingesetzt werden.

WENN können Sie immer dann einsetzen, wenn Sie abhängig davon, ob ein Wert oder eine Formel einer speziellen Bedingung genügt, einen bestimmten Vorgang auslösen möchten (z.B. eine Verzweigung). Das Ergebnis der Prüfung einer solchen Bedingung bestimmt, welchen Wert eine WENN-Funktion liefert.

Größer als 89 A
80 bis 89 B
70 bis 79 C
60 bis 69 D
Kleiner als 60 F


Sie können die folgende geschachtelte WENN-Anweisung verwenden:

WENN(Durchschnitt>89;"A";WENN(Durchschnitt>79;"B";WENN(Durchschnitt>69;"C";WENN(Durchschnitt>59;"D";"F"))))

In diesem Beispiel ist die zweite WENN-Anweisung das Argument Sonst_Wert der ersten WENN-Anweisung. Ähnliches gilt für die dritte WENN-Anweisung, die das Argument Sonst_Wert der zweiten WENN-Anweisung ist. Ergibt beispielsweise die erste Prüfung (Durchschnitt>89) das Ergebnis WAHR, wird "A" zurückgegeben. Ergibt die erste Prüfung das Ergebnis FALSCH, wird die zweite WENN-Anweisung ausgeführt usw.

In unserem Beispiel bedeutet dies:

  • Wenn der aktuelle Aktienkurs < ist als der Wert in Kaufen bei, dann sollte die Meldung KAUFEN erscheinen.
  • Wenn der aktuelle Aktienkurs > ist als der Wert in Verkaufen bei, dann sollte die Meldung VERKAUFEN erscheinen.
  • Wenn sich dieser Wert dazwischen bewegt, dann sollte die Meldung Behalten erscheinen.
Im Ergebnis sollte dies dann folgendermaßen aussehen:

Abbildung - So siehts aus
So siehts aus

In der Spalte MELDUNG stecken also WENN-Funktionen.

Für das erste Beispiel heißt dann die Funktion:

=WENN(B2<=C2;"KAUFEN";WENN(B2>=D2;"VERKAUFEN";"BEHALTEN"))

Die Schreibweise wird folgendermaßen interpretiert:

  • Das anfängliche =-Zeichen und das WENN deuten auf die WENN-Funktion hin.
  • In der Klammer danach wird die erste Bedingung festgelegt: Wenn der Aktienkurs kleiner/gleich dem Wert in der Zelle c4 ist, dann soll gekauft werden.
  • Die zweite Bedingung wird durch ein Semikolon von der ersten getrennt, aber noch in der ersten Klammer gesetzt, da es sich hier um eine verschachtelte Funktion handelt.
  • Die zweite Bedingung heißt: Wenn der Wert aus der Zelle b4 größer/gleich dem Wert aus der Zelle d4 ist, dann soll die Aktie verkauft werden.
  • Die dritte WENN-Funktion wird direkt an die zweite gehangen. Wenn beides nicht zutrifft, dann soll die Meldung Behalten erscheinen.

Rechnen innerhalb einer WENN-Funktion

Mit der WENN-Funktion kann man nicht nur Meldungen veranlassen, sondern auch differenzierte Berechnungen durchführen. Als Beispiel soll hier eine Skonto-Berechnungstabelle dienen. Erfaßt werden in dieser Tabelle der Rechnungsausgang und der Zahlungseingang. Berechnet werden muß hier noch die Anzahl der Tage die in diesem Zeitraum vergangen sind. Da Excel auch Datumsformate berechnen kann, ist dies durch eine einfach Subtraktion zu erreichen. Hier die Beispieltabelle:

Abbildung - Skontotabelle


Jetzt noch die Regeln für die Skontoberechnung:

  • Wenn der Zahlungseingang innerhalb von 10 Tagen erfolgt, ist ein Skontosatz von 3% abzuziehen.
  • Wenn der Zahlungseingang länger als 20 Tage dauert ist auf den Rechnungsbetrag eine Gebühr von 5% aufzuschlagen.
  • Wenn der Zahlungsbetrag zwischen diesen Zeiträumen liegt, bleibt der Rechnungsbetrag bestehen.
Berechnet werden muß zunächst der Skontoabzug oder der Versäumnisaufschlag. Hierzu muß folgende Wenn-Bedingung eingegeben werden:

=WENN(E3<10;B3*-0,03;WENN(E3>20;B3*0,05;0))


Abbildung - Skontoberechnung
Skontoberechnung

Abbildung - Formeln zur Skontoberechnung
Formeln zur Skontoberechnung