Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Gültigkeit - BEITRAG: 2 Gültigkeitdropdowns in Abhängigkeit


Aufgabe
Eine Gültigkeitsliste soll in Abhängigkeit einer anderen dynamisch erzeugt werden. Die 2. Auswahlliste enthält am Ende keine leeren Einträge.

In Abhängigkeit der Markenauswahl in H1 erfolgt die passende Typenauswahl in H2.
Alles über Daten-Gültigkeit-Liste - zudem werden die unterschiedlichen Bereichsgrößen (mal bis Zeile 4, dann 5 oder 6) dynamisch angepasst.
Es gibt also in der Gültigkeitsauswahlliste keine Leerzellen am Ende.

 
 ABCDEFGH
1OpelBMWDaimlerChryslerVWAudi MarkeBMW
2Vectra3erA-KlassePoloA3 TypZ1
3Omega5erC-KlasseGolfA4   
4Astra7erE-KlassePassatA6   
5AgilaZ1S-Klasse A8   
6 Z3Smart     
 



Lösung
Für die Markenauswahl in H1 unter Daten-Gültigkeit-Liste:
=$A$1:$E$1

Und in H2 für die dazugehörigen Typen (auch unter Daten-Gültigkeit-Liste):

=BEREICH.VERSCHIEBEN(A:E;1;VERGLEICH(H1;A1:E1;0)-1;ANZAHL2(INDEX(A:E;;VERGLEICH(H1;A1:E1;0)))-1;1)

Diese Array-Formel-Lösung (bei Gültigkeit muß man nicht mit Strg/Shift/Enter abschließen) ist nur dann nötig, wenn man für die gültigen Eintragungen ein Zellendropdown haben will.
Ohne drop-down-Liste wird es einfacher mit Zulassen: Benutzerdefiniert/Formel:
=ZÄHLENWENN(BEREICH.VERSCHIEBEN(A2;;VERGLEICH(H1;A1:E1;)-1;5;);H2)=1


Erläuterung
Innerhalb der Listeneinträge dürfen keine Leerzellen vorkommen.