Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Addition jeder X-ten Zahl


Aufgabe
Jede 4. Zahl eines Bereiches soll addiert werden. Da Leerzeilen vorkommen können, kann man nicht jede 4. Zeile addieren.

       A       
1 7  
2  
3 2  
4 5  
5 3  
6  
7 9  
8  
9 8  
10 11  
11  
12 1  
13 2  
14  
15 7  
16 12  
17 4  
18 6  
19  
20 Summe: 24 

Lösung
Spalte A
(mit erster Zahl beginnend)
{=SUMME((REST(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1:A100;;;ZEILE(1:100););"<1e+99");4)-1=0)*(A1:A100))}

Außer Zahlen werden bei dieser Formel nur Leere Zellen akzeptiert.
Leerzeichen oder Texte führen zur Fehlerausschrift #WERT!

{=SUMME(WENN((REST(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1:A100;;;ZEILE(1:100););"<1e+99");4)-1=0);(A1:A100)))}
akzeptiert auch Texte im Bereich