Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Addition von Zahlen (mit Zeilenumbruch) in einer Zelle


Aufgabe
In einer Zelle (A1) stehen durch Alt+Enter (Zeilenumbruch) getrennt mehrere Zahlen untereinander. Diese sollen summiert werden.


Lösung
Sind es nur einstellige Zahlen:
=SUMMENPRODUKT(("0"&TEIL(WECHSELN(A1;ZEICHEN(10););SPALTE(A1:IQ1);1))*1)

Bei nur 2 auch mehrstelligen Zahlen:
=SUMME(TEIL(A1;1;FINDEN(ZEICHEN(10);A1)-1);TEIL(A1;FINDEN(ZEICHEN(10);A1)+1;99))

Bei vielen mehrstelligen Zahlen (lupo1):
=SUMMENPRODUKT(GLÄTTEN(TEIL(WECHSELN(A1;ZEICHEN(10);WIEDERHOLEN(" ";999));ZEILE(INDIREKT("1:"&LÄNGE(A1)-LÄNGE(WECHSELN(A1;ZEICHEN(10);))+1))*999-998;999))*1)

oder
Selektiere Zelle B1 und vergib den Namen Zellsumme
mit bezieht sich auf:
=AUSWERTEN(WECHSELN(Tabelle1!A1;ZEICHEN(10);"+"))
schreibe in B1 =Zellsumme

Erläuterung
Die erste Formel ist nichts anderes als unsere Quersummenformel (Nr. 112 - mathematische Funktionen).