Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Alle Zahlen addieren, die in den gewünschten Monat fallen


Aufgabe
Eine Datumsspalte soll durchsucht werden und von einer benachbarten Spalte die Summe eines vorgegebenen Monats (im Beispiel: Januar) gebildet werden.

       A               B       
1 1.1.01  1000  
2 2.2.01  2000  
3 3.3.01  3000  
4 4.4.01  4000  
5 5.1.01  5000  
6 6.2.01  6000  
7 Ergebnis:  6000 



Lösung
Datumsspalte = A
Betragsspalte = B
Monat = Januar (=1)

{=SUMME(WENN(MONAT(A1:A100)=1;B1:B100))}

Achtung:
Sind in dem Bereich Leerzellen vorhanden, werden diese dem Januar zugeordent, da =MONAT(0) 1 ergibt. Um das zu verhindern schreibt man z.B. :
{=SUMME(WENN((MONAT(A1:A100)=1)*(A1:A100>0);B1:B100))}
wenn auch das Jahr relevant ist, dann
{=SUMME(WENN((MONAT(A1:A100)=1)*(A1:A100>0)*(JAHR(A1:A100)=2001);B1:B100))}