Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Alle Zeichen eines Strings auflisten


Aufgabe
Von einem in A1 eingegebenem String sollen alle vorkommenden Zeichen ohne Duplikate aufgelistet werden

       A               B       
1 Walter Fricke   
2   W  
3 a  
4 l  
5 t  
6 e  
7 r  
8  
9 F  
10 i  
11 c  
12 k  
13   #ZAHL!  
14   #ZAHL!  
15   #ZAHL!  
16   #ZAHL!  
17   #ZAHL!  
18   #ZAHL!  
19   #ZAHL!  
20   #ZAHL! 



Lösung
in B2:
{=TEIL(A$1;KKLEINSTE(WENN(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99);ZEILE($1:$99));ZEILEN(A$2:A2));1)}
und runter kopieren.

Mit Fehlerabfang:
{=WENN(ZEILEN(A$2:A2)>SUMME(N(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99)));"";TEIL(A$1;KKLEINSTE(WENN(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99);ZEILE($1:$99));ZEILEN(A$2:A2));1))}

Und die jugendfreie Variante ab A2, wobei die Zeichen nach der Codezahl aufsteigend aufgelistet werden, inkl. Fehlerabfang:
{=WENN(ZÄHLENWENN(A$1:A1;ZEICHEN(MAX(CODE(TEIL(A$1;SPALTE($1:$1);1)&"!"))));"";ZEICHEN(KKLEINSTE(WENN(LÄNGE(A$1)-LÄNGE(WECHSELN(A$1;ZEICHEN(ZEILE($32:$255));));ZEILE($32:$255);"");ZEILE(A1))))}