Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Anzahl Leerzeilen/gefüllter Zeilen in einem Tabellenbereich *


Aufgabe
Du willst wissen, wie viele Leerzeilen in einem Bereich enthalten sind.

       A               B               C               D               E               F               G       
1            
2            
3              
4            
5          
6              
7             x  
8              
9            
10            
11 Leere  Zeilen:  3         

Lösung
Tabelle: A1:G10

=SUMMENPRODUKT((ANZAHLLEEREZELLEN(BEREICH.VERSCHIEBEN(A1:G1;ZEILE(1:10)-1;;;))=7)*1)

mit MMULT (Franz Pölt):
=SUMME(1*(MMULT(1*(ISTLEER(A1:G10));ZEILE(1:7)^0)=7))

Erläuterung
<7 statt =7 liefert Dir jeweils die Zeilenzahl mit Werten.