Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Anzahl der Zeilenminima pro Spalte


Aufgabe
In den Zeilen stehen Zahlen (im Beispiel jeweils 4).
Davon ist eine logischerweise das Minimum (kann auch mehrfach vorkommen).
Pro Spalte möchtest Du die Anzahl der Minima bestimmen.

       A               B               C               D       
1 1  4  
2 2  5  
3 10  4  8  
4 3  11  
5 1  6  
6 12  5  5  
7        
8        
9 2  0  4  1 


Lösung
Schreibe in A9:
=SUMME(1*(MMULT((A1:A8>$A1:$D8)-($A1:$D8="");ZEILE(1:4)^0)=0))
nach rechts kopieren


Erläuterung
A bis D sind 4 Spalten - darum ZEILE(1:4)^0 in der Formel.
Stattdessen könntest Du auch die Matrixkonstante {1;1;1;1} nehmen. Bei 50 Spalten wäre das aber ziemlich lästig.