Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Anzahl der "echten" Vorzeichenwechsel in einer Spalte


Aufgabe
Es sollen die Vorzeichenwechsel in einer Spalte gezählt werden.
Dabei sollen die Wechsel auf/von null (leer) unberücksichtigt bleiben.

       A               B               C       
1 -1  4  
2 -17  -1  ohne null/leer  
3 -3  -1   
4 -1   
5   -1  8  
6 23  mit null/leer  
7  
8 0,04   
9  
10 -5  -1   
11 456   
12  
13 12   
14 -1,75  -1   
15   -1   
16   -1   
17   -1   

Lösung
In B1 (Hilfsspalte) steht:
{=VORZEICHEN(INDEX(A:A;MIN(WENN(A1:A30<>0;ZEILE(1:30)))))}
Steht in A1 eine Zahl ungleich null (leer) langt:
=VORZEICHEN(A1)

In B2:
=WENN(A2=0;B1;VORZEICHEN(A2))
B2 bis über das Bereichsende (hier 30) hinaus runterkopieren.

das Ergebnis:
=SUMMENPRODUKT(ABS((B2:B30)-(B1:B29))/2)
bzw.
falls B2 nicht weit genug runterkopiert wurde (nur bis letzte Zahl in Spalte A):
=GANZZAHL(SUMMENPRODUKT(ABS((B2:B30)-(B1:B29))/2))



Alle Vorzeichenwechsel - inklusive null/leer - erhält man (ohne Hilfsspalte) mit:
=SUMMENPRODUKT((VORZEICHEN(A2:A30)<>VORZEICHEN(A1:A29))*1)