Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Anzahl unterschiedlicher Einträge in mehreren Spalten


Aufgabe
Wie kann man die Anzahl unterschiedlicher Einträge bezogen
auf mehrere Spalten ermitteln ?
Also zählen von unterschiedlichen Datensätzen (Kombinationen)

       A               B       
1 1  2  
2 3  4  
3 3  2  
4 2  
5 1  3  
6 4  
7    
8 Ergebnis  4 



Lösung
Spalten: A & B

=SUMMENPRODUKT((VERGLEICH(A1:A99&"x"&B1:B99;A1:A99&"x"&B1:B99;0)=ZEILE(1:99))*1)-1
-1 ist notwendig, da für Leerzellen 1 addiert wird.

Wenn unsicher ist, ob Leerzellen vorkommen können, dann:
=SUMMENPRODUKT((VERGLEICH(A1:A99&"x"&B1:B99;A1:A99&"x"&B1:B99;0)=ZEILE(1:99))*(A1:A99<>"")*(B1:B99<>""))

Erläuterung
...&"x"... ist nötig, da sonst z.B. 31 und 5 identisch wäre zu 3 und 15.