Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Anzahl von Worten aus einer Liste in einem Satz


Aufgabe
In A1 bis A9 stehen Worte. Es soll gezählt werden, wie viele davon in einem Satz vorkommen.

       A               B               C       
1 Birne    Die Gurke, die Limette und der Apfel sind grün.  
2 Apfel    2  
3 Gurke     
4 Erdbeere    Willst Du Kiwi oder Mango? Lieber Mango statt Kiwi.  
5     4  
6 Mango     
7 Kiwi     
8      
9 Orange     


Lösung
{=ANZAHL(FINDEN(WENN(A1:A9="";"µ";A1:A9);C1))}

Obige Formel zählt mehrfach vorkommende Worte nur einmal. Sollen alle gezählt werden:
{=SUMME((LÄNGE(C4)-LÄNGE(WECHSELN(C4;A1:A9;)))/WENN(A1:A9="";1;LÄNGE(A1:A9)))}

Kommen in A1 bis A9 keine Leerzellen vor, wird's kürzer:
{=ANZAHL(FINDEN(A1:A9;C1))}
{=SUMME((LÄNGE(C4)-LÄNGE(WECHSELN(C4;A1:A9;)))/LÄNGE(A1:A9))}