Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlensysteme - BEITRAG: Arabische Zahl in römische Zahl umwandeln und umgekehrt *


Aufgabe
Wie kann man arabische in römische Zahlen umwandeln und vor allem umgekehrt ?

       A               B       
1 2230  MMCCXXX  
2 797  DCCXCVII  
3 1998  MCMXCVIII  
4 3218  MMMCCXVIII  
5 1358  MCCCLVIII  
6 65  LXV  
7 2611  MMDCXI  
8 581  DLXXXI  
9 1520  MDXX  
10 2035  MMXXXV 

Lösung
arabisch > römisch:
=RÖMISCH(A1)

römisch > arabisch
{=VERGLEICH(A1;RÖMISCH(ZEILE(INDIREKT("$1:$3999")));0)}

Funktioniert in beide Richtungen bis 3.999

Ergänzung vom 17.11.2004:
für Zahlen von minus 4.999 bis plus 4.999

=WENN(A1<0;"-";"")&WENN(ABS(A1)>3999;"M"&RÖMISCH(ABS(A1)-1000);RÖMISCH(ABS(A1)))

{=(VERGLEICH(TEIL(A2;WENN(TEIL(A2;4+(LINKS(A2)="-");1)="M";2;1)+(LINKS(A2)="-");20);RÖMISCH(ZEILE(INDIREKT("$1:$3999")));0)+WENN(TEIL(A2;4+(LINKS(A2)="-");1)="M";1000;0))*WENN(LINKS(A2)="-";-1;1)}


Nur ne Spielerei: arabisch > römisch ohne die Funktion RÖMISCH
=WIEDERHOLEN("M";(A1/1000))&WAHL(KÜRZEN(RECHTS(A1;3)/100)+1;"";"C";"CC";"CCC";"CD";"D";"DC";"DCC";"DCCC";"CM")&WAHL(KÜRZEN(RECHTS(A1;2)/10)+1;"";"X";"XX";"XXX";"XL";"L";"LX";"LXX";"LXXX";"XC")&WAHL(RECHTS(A1)+1;"";"I";"II";"III";"IV";"V";"VI";"VII";"VIII";"IX")

Erläuterung
Ab Excel-2010 gibt es neben RÖMISCH auch die Funktion ARABISCH
römisch > arabisch also:
=ARABISCH(A1)
Diese Funktion produziert allerdings auch Müll. Die "römische Zahl" VVVX z.B., die es logischerweise nicht gibt, wird gnadenlos umgewandelt zu arabisch -5.