Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Verweisfunktionen - BEITRAG: Array aus diskontinuierlichem Bereich


Aufgabe
Einen Array aus einem diskontinuierlichem Bereich zu erzeugen, der auch noch diagrammfähig ist, war bislang nur mit Zahlen möglich.
Siehe dazu:
Diagramm Nr.29


Mit der Funktion T funktioniert es auch für Text, z.B. kann eine Diagonale nach einem Begriff durchsucht werden

       A               B               C               D               E               F               G               H               I       
1             Suchbegriff  d  
2             Position  4  
3                
4       d           
5                
6                
7                
8                

Lösung
Die zu durchsuchende Diagonale beginnt in A1.
Der gesuchte Begriff steht in I1
Die Position in der Diagonalen ist
{=VERGLEICH(I1;T(INDIREKT(ADRESSE(ZEILE(1:10);ZEILE(1:10))));0)}

Wird nach einer Zahl gesucht lautet die Formel
{=VERGLEICH(I1;N(INDIREKT(ADRESSE(ZEILE(1:10);ZEILE(1:10))));0)}

Vergibt man für so einen Array Namen, läßt es sich auch in einem Diagramm benutzen (siehe Download)

DOWNLOAD mit Diagrammbeispiel (5kb)