Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Auf halbe Stunden runden bzw. auf nächste halbe Stunde aufrunden


Aufgabe
Ich möchte eine gegebene Uhrzeit auf eine halbe Stunde, oder einen anderen Anteil einer Stunde runden (auf bzw. abrunden).
Ich möchte immer auf die nächste halbe Stunde aufrunden ?

Beispiele:

       A               B               C               D       
1 Zeit  Std.teil  Runden  Aufrunden  
2 07:44  4   07:45  07:45  
3 13:05  1   13:00  14:00  
4 10:46  3   10:40  11:00  
5 10:16  6   10:20  10:20  
6 01:55  3   02:00  02:00  
7 09:34  1   10:00  10:00  
8 20:52  2   21:00  21:00  
9 02:35  4   02:30  02:45  
10 19:41  6   19:40  19:50  
11 23:22  3   23:20  23:40 

Lösung
Datum steht in A1
Stundenanteil steht in B1

Runden:
=RUNDEN(A1*24*B1;0)/(24*B1)

Aufrunden:
=OBERGRENZE(A1;1/(24*B1))