Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Auflistung aller mehrfach vorkommenden Einträge einer Spalte


Aufgabe
Du willst wissen, welche Einträge (Zahlen und/oder Texte) in einer Liste mehrfach vorkommen. Die mehrfach vorkommenden Einträge sollen jeweils nur einmal aufgeführt werden.

       A               B               C               D       
1 Spanien  vino  3  Osborne  
2 vino  Osborne    103  
3 Osborne  cerveza     
4 cerveza  103     
5 103  Gin     
6 vino       
7 103       
8 Osborne       
9 103       
10 cerveza       
11 Osborne       
12 Gin       
13 Carlos       
14 Gin       


Lösung
Spalte: A

schreibe in B1:
{=WENN(ZEILE(A1)>SUMME(WENN(A$1:A$99="";0;1/(ZÄHLENWENN(A$1:A$99;A$1:A$99)));-(ZÄHLENWENN(A$1:A$99;A$1:A$99)=1)*1);"";INDIREKT("A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("A1:A"&ZEILE($1:$99));A$1:A$99)=1)*(ZÄHLENWENN(A$1:A$99;A$1:A$99)>1);ZEILE($1:$99));ZEILE(A1))))}
Diese Formel runterkopieren.

Ergänzung:
Willst Du explizit wissen, welche Einträge einfach, doppelt, dreifach etc. vorkommen, dann die gewünschte Anzahl in C1 und in D1:
{=WENN(ZEILE(A1)>SUMME((ZÄHLENWENN(A$1:A$99;A$1:A$99)=$C$1)*1)/$C$1;"";INDIREKT("A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("A1:A"&ZEILE($1:$99));A$1:A$99)=1)*(ZÄHLENWENN(A$1:A$99;A$1:A$99)=$C$1);ZEILE($1:$99));ZEILE(A1))))}
runterkopieren


Erläuterung
Neben der Ergänzung wurde in der ersten Formel noch die Fehlermeldung, wenn kein Treffer mehr vorkommt, vermieden.