Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Excel4-Makrofunktionen - BEITRAG: Auflistung aller vergebenen Namen der Arbeitsmappe


Aufgabe
Du willlst eine Liste mit allen vergebenen Namen der Arbeitsmappe inklusive Bezüge erstellen.
Lösung
Wähle
Einfügen>Namen>Definieren
Name:"Namen"
bezieht sich auf:=NAMEN(;3;"*")

Schreibe in B1
=WENN(ZEILE()>ANZAHL2(Namen);"";INDEX(Namen;ZEILE()))
und kopiere dies nach unten

Selektiere C1 und wähle Einfügen>Namen>Definieren
Name:"Bezug"
bezieht sich auf:=NAMEN.ZUORDNEN(B1)
Schreibe in C1 =WENN(B1<>"";Bezug;"")
und kopiere dies nach unten, damit erhälst Du die Bezüge der Namen.

Im 3. Argument kann anstelle des "*" ein Filterkriterium eingebaut werden. Steht im 3. Argument z.B. "*Bereich*", werden nur die Namen
aufgelistet, die den Text "Bereich" beinhalten
Erläuterung
Die Excel4-Makrofunktionen haben prinzipiell Neuberechnungsprobleme bei Änderungen.
Das ist ähnlich wie bei benutzerdefinierten VBA Funktionen. Um eine Neuberechnung zu erzwingen, muß man strg+alt+F9 statt
nur F9 drücken.

Oder man fügt INDIREKT an die Funktion an, also =NAMEN(;3;"*")&INDIREKT("IV65536"). (in IV65536 darf natürlich nichts stehen).
Mit diesem Trick wird die Funktion bei jeder Neuberechnung aktualisiert.