Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Ausschließlichkeitsprüfung von Zeichen


Aufgabe
Es soll überprüft werden, ob in der Zeichenfolge in A1 nur die vordefinierten Zeichen aus D1 vorkommen.

in D1 steht z.B.: akCLdNz$1,:!
in A1: AL,CD => OK
in A1: $AC2 => enthält ungültige Zeichen
in A1: M => enthält ungültige Zeichen
in A1: anna! => OK

Lösung
{=WENN(ANZAHL(SUCHEN(TEIL(A1;ZEILE(X1:X99);1);D1;1))=99;"OK";"enthält ungültige Zeichen")}

ohne Abschluß als Arrayformel:
=WENN(ISTZAHL(SUMMENPRODUKT(SUCHEN(TEIL(A1;ZEILE(X1:X99);1);D1;1)));"OK";"enthält ungültige Zeichen")


Erläuterung
Soll auch GROSS-und-klein-Schreibung unterschieden werden, dann in der Formel FINDEN statt SUCHEN eingeben. Mit FINDEN werden auch die Zeichen/Joker * und ? richtig behandelt, die bei SUCHEN immer als vorhanden gelten.