Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Bei Duplikaten Werte anderer Spalte nur einmal addieren *


Aufgabe
Du hast Einträge in einer Spalte (z.B. Auftragsnummern =Texte) die mehrfach vorkommen können.
In Spalte B stehen die jeweiligen Auftragsvolumina. Diese sollen jetzt addiert werden, wobei natürlich jedes Auftragsvolumen nur einmal berücksichtigt werden darf.

       A               B       
1 Auftrag  Volumen  
2 0001  1500  
3 0002  4000  
4 0001  1500  
5 0003  2700  
6    
7 0004  3300  
8 0002  4000  
9 0005  6100  
10 0001  1500  
11 0005  6100  
12    
13 Summe  17600 

Lösung
Suchspalte: A
Zu berechnende Spalte: B

{=SUMME(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1;;;ZEILE(1:99));A1:A99)=1;B1:B99))}

Variante von neopa:
=SUMMENPRODUKT(1*(VERGLEICH(""&A1:A99;""&A1:A99;)=ZEILE(1:99));B1:B99)

Erläuterung
Soll wie im obigen Beispiel die Summe in B13 stehen, muss (wegen Zirkelbezug) in den Formeln :99 auf :12 geändert werden.