Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Beim Löschen von Zeilen die Fehlermeldung #BEZUG! vereiteln


Aufgabe
In Zelle C1 der Tabelle1 steht z.B. eine Summenformel - nicht von/bis - sondern explizit:
=SUMME(A8;A11;A16;A18;A26;A28)
Wird jetzt eine dieser Zeilen gelöscht, erhalten wir als Ergebnis #BEZUG!

Wann nicht?


Lösung
Gehe auf D1 und vergebe einen Namen z.B. Petra mit bezieht sich auf
=ZELLE.ZUORDNEN(6;Tabelle1!C1)
schreibe in D1 =Petra

schreibe in E1:
=TEIL(WECHSELN(D1;"#BEZUG!";);2;999)

Gehe auf F1 und vergebe einen Namen z.B. voilà mit bezieht sich auf
=AUSWERTEN(INDIREKT("Tabelle1!E1"))
schreibe in F1 =voilà


Erläuterung
Wie funktioniert diese Formelkette?

Wird z.B. die Zeile 11 gelöscht, sehen wir
in C1: =#BEZUG!
in D1 (dort steht =Petra): =SUMME(A8;#BEZUG!;A15;A17;A25;A27)
in E1 wird durch das WECHSELN der Bezugsfehler eliminiert und wegen TEIL(...;2;...) ohne Gleichheitszeichen: SUMME(A8;;A15;A17;A25;A27)
in F1 (dort steht =voilà): das Ergebnis.