Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Berechnung der alternierenden Quersumme einer Zahl


Aufgabe
Bei der alternierenden Quersumme (Wechselquersumme) wird rechts begonnen und von Ziffer zu Ziffer das Vorzeichen gewechselt. Das erste Vorzeichen ist positiv.

Ist die alternierende Quersumme durch 11 teilbar oder Null, ist die Zahl selbst auch durch 11 teilbar.

       A               B       
1 954204025279051364656733  4  
2 549964493915305851208268  2  
3 129294  -11  
4 596381498528767779301087  -2 

Lösung
Zahl steht in A1

=SUMMENPRODUKT(LINKS(RECHTS(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1))));1)*-1^(1+ZEILE(INDIREKT("1:"&LÄNGE(A1)))))

kürzer:
=SUMMENPRODUKT((0&TEIL(A1;SPALTE(1:1);1))*(1-REST(SPALTE(1:1)-REST(LÄNGE(A1);2);2)*2))