Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Berechnung eines Arrays ohne {geschweifte} Klammern


Aufgabe
Mit den Funktionen MMULT, INDEX und SUMMENPRODUKT können Array-Berechnungen durchgeführt werden, ohne dass man mit strg+umschalt+enter die {geschweiften} Klammern erzeugen muss.

Lösung
Beispiel 1: SUMMEWENN mit zwei Bedingungen:
=SUMMENPRODUKT((A1:A100="x")*(B1:B100="y")*C1:C100)
Siehe auch Formel Nr.61
Mit WENN-Bedingungen innerhalb der Formel funktioniert es nicht

Beispiel 2: Anzahl unterschiedlicher Einträge eines Bereiches (ohne Leerzellen):
=SUMMENPRODUKT(1/ZÄHLENWENN(A1:A100;A1:A100))
Siehe auch Formel Nr.42

Beispiel 3: die Zeile des letzten Eintrages einer Spalte ist:
{=MAX((A1:A100<>"")*ZEILE(1:100))}
stattdessen:
=MMULT(MAX((A1:A100<>"")*ZEILE(1:100));1)
bzw.
=INDEX(MAX((A1:A100<>"")*ZEILE(1:100));0)
bzw.
=SUMMENPRODUKT(MAX((A1:A100<>"")*ZEILE(1:100)))
Siehe auch Formel Nr.48

Erläuterung
Der wesentliche Unterschied zwischen MMULT / INDEX und SUMMENPRODUKT ist der, dass MMULT / INDEX ein Array liefert, das Ergebnis von SUMMENPRODUKT hingegen ist stets ein einzelner Wert.