Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Bestimmte Zeichen in einer Zelle/Spalte zählen


Aufgabe
Wie kannst Du das Vorkommen von bestimmten Buchstaben in einer Zelle zählen ?

       A               B       
1 Popokatepetel  3+2=5  
2 Popokatepetel  3 

Lösung
=SUMMENPRODUKT((TEIL(A1;SPALTE(1:1);1)={"p";"t"})*1)
=SUMMENPRODUKT((TEIL(A1;SPALTE(1:1);1)="p")*1)

oder:
=LÄNGE(A1)-LÄNGE(WECHSELN(WECHSELN(KLEIN(A1);"p";);"t";))
=LÄNGE(A1)-LÄNGE(WECHSELN(KLEIN(A1);"p";))
mit
=LÄNGE(A1)-LÄNGE(WECHSELN(A1;"p";)) werden nur die kleinen "p" gezählt.

Einzelne Buchstaben in mehreren Zellen zählen funktioniert mit:
=SUMMENPRODUKT(LÄNGE(A1:A99)-LÄNGE(WECHSELN(KLEIN(A1:A99);"p";)))