Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Bestimmtes Wort in einem Bereich zählen


Aufgabe
Wie oft kommt das Wort "der" in einem Bereich vor.
Das Wort kann in einer Zelle mehrmals vorkommen.

Lösung
Bereich: A1:A10
Wort steht in B1, z.B. "der" (ohne Anführungszeichen)

überprüft die genaue Schreibweise (GROSS / klein):
{=SUMME((LÄNGE(A1:A10)-LÄNGE(WECHSELN(A1:A10;B1;"")))/LÄNGE(B1))}

unterscheidet nicht, ob: der / Der / DER
{=SUMME((LÄNGE(A1:A100)-LÄNGE(WECHSELN(KLEIN(A1:A100);KLEIN(B1);"")))/LÄNGE(B1))}


Soll "der" nur alleinstehend gezählt werden ("der oder der" = 2 und nicht 3):
{=SUMME((LÄNGE(" "&A1:A10&" ")-LÄNGE(WECHSELN(" "&A1:A10&" ";" "&B1&" ";"")))/(LÄNGE(B1)+2))}
bzw.
{=SUMME((LÄNGE(" "&A1:A10&" ")-LÄNGE(WECHSELN(" "&KLEIN(A1:A10)&" ";" "&KLEIN(B1)&" ";"")))/(LÄNGE(B1)+2))}

Die Anzahl der Zellen, in denen "der" vorkommt, liefert:
{=ANZAHL(SUCHEN(B1;A1:A100))}
bzw. alleinstehend:
{=ANZAHL(SUCHEN(" "&B1&" ";" "&A1:A100&" "))}