Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Buchstaben von rechts suchen und finden mit Array-Formel


Aufgabe
Die FINDEN bzw.SUCHEN-Funktion fängt bei eine Text immer
links an. Was machst Du, wenn das letzte Zeichen z.B. "e" gesucht wird
bzw. das erste von rechts ?

       A               B               C       
1 Jens Fleckenstein  (von rechts)  
2   15  (von links) 

Lösung
Gibt die Position von rechts an:
{=VERGLEICH("e*";RECHTS(A1;SPALTE(1:1));0)}

Gibt die Position von links an:
{=MAX((TEIL(A1;SPALTE(1:1);1)="e")*SPALTE(1:1))}