Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Buchstaben(folgen) in einer Spalte zählen


Aufgabe
Es soll das Vorkommen eines bestimmten Buchstabens / einer Buchstabenfolge in einer Spalte gezählt werden.

       A               B       
1 Hund  und  
2 Erkundung   
3 Underberg   
4 Umtrunk   
5 Rundung   
6 runder Mund   
7    
8    
9 Anzahl:  5 


Lösung
nachfolgender Array zählt alle großen U in Spalte A:
=SUMMENPRODUKT((LÄNGE(A1:A99)-LÄNGE(WECHSELN(A1:A99;"U";""))))

sollen alle großen U und kleinen u gezählt werden, dann:
=SUMMENPRODUKT((LÄNGE(A1:A99)-LÄNGE(WECHSELN(KLEIN(A1:A99);"u";""))))

Bei einer Buchstabenfolge (sie steht in B1) :
=(SUMMENPRODUKT(LÄNGE(A1:A99)-LÄNGE(WECHSELN(A1:A99;B1;"")))/LÄNGE(B1))

Soll nur das konkrete Wort in B1 gezählt werden (und: ja / Rundung: nein)
=SUMMENPRODUKT((LÄNGE(" "&A1:A99&" ")-LÄNGE(WECHSELN(" "&A1:A99&" ";" "&B1&" ";)))/(LÄNGE(B1)+2))

Wenn noch Satzzeichen eliminiert werden müssen (jetzt nur Punkt und Komma):
=SUMMENPRODUKT((LÄNGE(" "&A1:A99&" ")-LÄNGE(WECHSELN(WECHSELN(WECHSELN(" "&A1:A99&" ";".";" ");",";" ");" "&B1&" ";)))/(LÄNGE(B1)+2))