Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Bedingte Formatierung - BEITRAG: Datensatzduplikate markieren


Aufgabe
Alle Datensätze, die zum wiederholten Male auftreten, sollen markiert werden. Originale sollen nicht markiert werden.

       A               B               C               D       
1 45  47  24  39  
2 38  36  11  19  
3 11  16  12  
4 29  18  42  27  
5 29  18  42  27  
6 47  45  11  35  
7 46  27  32  14  
8 38  36  11  18  
9 38  36  11  19  
10 39  24  27 

Lösung
Datensätze stehen in Spalte A bis Spalte D

Markiere A1:D100
A1 ist die aktive Zelle

Die Formel der Bedingung lautet
=VERGLEICH($A1&$B1&$C1&$D1;$A$1:$A$100&$B$1:$B$100&$C$1:$C$100&$D$1:$D$100;0) < ZEILE()

sollen alle mehrfachkommenden markiert werden, also auch schon beim ersten auftreten, dann lautet die Formel
=SUMME(WENN($A1&$B1&$C1&$D1=$A$1:$A$100&$B$1:$B$100&$C$1:$C$100&$D$1:$D$100;1)) > 1


Durch die Verkettung sind Datensätze wie 22,33,44,5 und 2,23,34,45 identisch - denn beide werden verkettet zu : 2233445
Um das auszuschließen: ein Trennzeichen dazwischen setzen:
=VERGLEICH($A1&";"&$B1&";"&$C1&";"&$D1;$A$1:$A$100&";"&$B$1:$B$100&";"&$C$1:$C$100&";"&$D$1:$D$100;0) < ZEILE()

Das Selbe gilt für die SUMME-Formel.