Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Datenzeile mit grösster Gesamtsumme ermitteln


Aufgabe
Du hast Datensätze mit mehreren Betragsfeldern und willst den Datensatz mit
größter Gesamtsumme ermitteln (ohne Hilfsspalte).

       A               B               C               D               E               F               G               H       
1 Andy  Klaus  Jens  Walter  Jürgen  Monat     
2 619  575  794  314  815  Januar    3392  
3 515  914  412  469  320  Februar     
4 607  811  257  747  970  März     
5 768  496  910  146  369  April     
6 100  866  531  197  799  Mai     
7 280  988  128  825  944  Juni     
8 648  504  191  872  766  Juli     
9 269  536  739  353  806  August     
10 555  296  859  941  658  September     
11 341  359  607  931  100  Oktober     
12                
13 Maximum  3392             
14 Zeile             
15 Monat  März             

Lösung
ListenBereich: A1:E100

Summe Max-Datensatz:
in H1
{=MAX(SUMMEWENN(BEREICH.VERSCHIEBEN(A1:E1;ZEILE(1:100)-1;;;);"<>0"))}

Zeilennummer dieses Datensatzes:
{=VERGLEICH(H1;SUMMEWENN(BEREICH.VERSCHIEBEN(A1:E1;ZEILE(1:100)-1;;;);"<>0");0)}

der Monat
{=INDEX(F:F;VERGLEICH(H1;SUMMEWENN(BEREICH.VERSCHIEBEN(A1:E1;ZEILE(1:100)-1;;;);"<>0");0))}


Alternative mit MMULT (ohne { } ,strg+umschalt+enter entfällt):

in H1:
=MAX(MMULT((A1:E100)*1;ZEILE(1:5)/ZEILE(1:5)))

Zeilennummer:
=VERGLEICH(H1;MMULT((A1:E100)*1;ZEILE(1:5)/ZEILE(1:5));0)

Monat:
=INDEX(F:F;VERGLEICH(H1;MMULT((A1:E100)*1;ZEILE(1:5)/ZEILE(1:5));0))