Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Datumsdifferenz in Monaten und Tagen der Monatsrümpfe


Aufgabe
Eine Datumsdifferenz soll in kompletten Monaten, dem Monatsrumpf (in Tagen) vorher und dem Monatsrumpf hinterher dargestellt werden.
Vom 21.02.2016 bis 25.05.2016 z.B. sind es 9 Tage - 2 Monate - 25 Tage

Lösung
In A1 steht das Beginndatum - in B1 das Enddatum.

Monatsrumpf (Tage) vorher:
=WENN((MIN(B1;DATUM(JAHR(A1);MONAT(A1)+1;0))-A1+1)=32-TAG(A1-TAG(A1)+32);0;(MIN(B1;DATUM(JAHR(A1);MONAT(A1)+1;0))-A1+1))

ganze Monate:
=MAX(0;(JAHR(B1+1)-JAHR(A1-1))*12+MONAT(B1+1)-MONAT(A1-1)-1)

Monatsrumpf (Tage) hinterher:
=TAG(B1)*(MONAT(B1)/99+JAHR(B1)>MONAT(A1)/99+JAHR(A1))*(MONAT(B1+1)=MONAT(B1))

Erläuterung
Es ist schwieriger, als man denkt.