Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Der letzte/erste Tag des Monats + bestimmter Wochentag


Aufgabe
Von einem vorgegebenen Datum soll der letzte, der erste Tag bzw. ein bestimmter, letzter/erster Wochentag des Monats ermittelt werden.

Lösung
Datum steht in A1

=DATUM(JAHR(A1);MONAT(A1)+1;0)
ersetzt die AddInn-Funktion =MONATSENDE(A1;0)
nur den Tag liefert:
=32-TAG(A1-TAG(A1)+32)

Der erste Tag im Monat lautet:
=DATUM(JAHR(A1);MONAT(A1);1)
oder
=A1-TAG(A1)+1
den jeweils 1. Januar liefert:
=1*(1&-JAHR(A1))

Soll ein bestimmter, letzter Wochentag des Monats ermittelt werden - der Wochentag steht in A2 (1=Mo bis 7=So) von Tobias Wutschka:
=DATUM(JAHR(A1);MONAT(A1)+1;)-REST(DATUM(JAHR(A1);MONAT(A1)+1;6-A2);7)
Verkürzt von Erich Gier:
=7*KÜRZEN(DATUM(JAHR(A1);MONAT(A1)+1;6-A2)/7)+A2-6

Der erste, bestimmte Wochentag in A2 des Monats (1=Mo bis 7=So) ist:
=7*KÜRZEN(DATUM(JAHR(A1);MONAT(A1);6-A2)/7)+A2+1

Steht der so ermittelte, erste Wochentag in A4, sind die restlichen im Monat ab A5:
=WENN(TAG(A4+7)<8;"";A4+7)
bis A8 runterkopieren