Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Iteration - BEITRAG: Dezimalzahl in beliebiges Zahlensystem umwandeln


Aufgabe
Mit Iteration kann eine Umwandlung einer Dezimalzahl in ein beliebiges Zahlensystem vorgenommen werden.

Siehe dazu auch Nr.262

       A               B               C       
1 100  Dezimalzahl:  31  
2 1F  Basis:  16  
3 Ausgabe:  1F  
4    
5    


Lösung
Aktiviere unter "Extras-Optionen-Berechnen" die Iteration.

A1: =WENN(A1=100;1;A1+1)
A2: =WENN(A1=1;"";WENN(A3=0;"";A5)&A2)
A3: =WENN(A1=1;C1;GANZZAHL(A3/C2))
A4: =A3-C2*GANZZAHL(A3/C2)
A5: =WENN(A4<10;A4;ZEICHEN(55+A4))
und Spalte A ausblenden
B1: Text: 'Eingabe Dezimalzahl'
B2: Text: 'Eingabe Basis'
B3: Text: 'Ausgabe'
C1 ist die Eingabezelle für die Dezimalzahl
C2 ist die Eingabezelle für die Zahlenbasis
C3: =A2 (ist die Ausgabezelle)