Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Die Funktion RANG funktioniert nicht mit Arrayformeln


Aufgabe
In Spalte A und Spalte B stehen Werte, die miteinander multipliziert werden.
Aus den Multiplikationsergebnissen ohne Ergebnis null soll die entsprechende Rangstelle ermittelt werden.

       A               B               C               D               E       
1       absteigend  aufsteigend  
2 183  1098  9  
3   0     
4 175  1050  7  
5 175  875  5  
6 210  1050  7  
7 172  -2  -344  2  
8     0     
9 182  1274  10  
10   -3  0     
11 -176  -704  10  1  
12 169    0     
13 174  1044  6  
14 172  860  4  
15     0     
16 171  342  3  
17     0     
18     0     

Lösung
Mit Hilfsspalte C ist's einfach: in C2: =A2*B2 und runterkopieren - die RANG-Funktion dann auf die Spalte C anwenden.

Ohne Hilfsspalte:
{=RANG(A2*B2;(A$2:A$99)*(B$2:B$99))} wird mit ner Fehlermeldung quittiert.

So geht's ohne die Funktion RANG:
=WENN(A2*B2=0;"";SUMMENPRODUKT((1*(A2*B2 < A$2:A$99*B$2:B$99)))+1-SUMMENPRODUKT((A$2:A$99*B$2:B$99=0)*(A2*B2 < 0)))
und runterkopieren

Soll die Rangfolge aufsteigend sein (Spalte E), die zwei < in der Formel in > ändern.




Erläuterung
Das zweite SUMMENPRODUKT in der Formel ist notwendig wegen Leerzellen.
Die zu multiplizierenden Spalten kann man natürlich gnadenlos erweitern.