Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Die Monatstage eines Zeitraums auflisten


Aufgabe
Wie der Titel schon sagt.

       A               B               C               D               E               F               G               H               I       
1 Zeitraum                 
2 von  bis    Dez 07  Jan 08  Feb 08  Mrz 08  Apr 08  Mai 08  
3 24.12.2007  11.05.2008    8  31  29  31  30  11 


Lösung
Das Anfangsdatum steht in A3, das Enddatum in B3.
Das Enddatum darf nicht vor dem Anfangsdatum liegen.

in D2 steht:
=DATUM(JAHR(A3);MONAT(A3)+1;)

in D3 steht:
=MIN(D2;$B3)-A3+1

in E2 steht (Josef Burch):
=WENN($B3<=D2;"";DATUM(JAHR(D2);MONAT(D2)+2;0))
oder
=WENN($B3<=D2;"";D2+32-TAG(D2+32))

in E3 steht:
=WENN(E2="";"";MIN(E2;$B3)-D2)

E2 und E3 nach rechts kopieren.
Zeile 2 erhält das benutzerdefinierte Format: MMM JJ