Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Die Ziffern einer Zahl von links nach rechts drehen (spiegeln) + Texte


Aufgabe
Die Ziffern einer Zahl sollen in umgekehrter Reihenfolge, also von rechts beginnend dargestellt (gespiegelt) werden.

       A               B       
1 Ziffern  umgedreht  
2 3284560  0654823  
3 1234567  7654321  
4 2930294  4920392 


Lösung
Die zu konvertierende Zahl steht in A1.
Das Ergebnis ist ein Text, der führende Nullen anzeigt.
{=TEXT(SUMMENPRODUKT(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*10^(ZEILE(INDIREKT("1:"&LÄNGE(A1)))-1));WIEDERHOLEN("0";LÄNGE(A1)))}

Das Ergebnis ist eine Zahl, ohne führende Nullen.
=SUMMENPRODUKT(TEIL(A1*10^(16-LÄNGE(A1));ZEILE(1:16);1)*10^(ZEILE(1:16)-1))
kürzer und mit führenden Nullen:
=SUMMENPRODUKT((0&TEIL(A1;ZEILE(1:16);1))*10^(ZEILE(1:16)-1))

Oder aber mit Hilfszellen (funktioniert auch bei Text)
Schreibe in B1 - da erscheint dann auch das Ergebnis:
=B2&TEIL(A$1;ZEILE(A1);1)
B1 runterkopieren

Erläuterung
!!!Bei den SUMMENPRODUKT-Formeln darf die Zahl höchstens 15 Stellen haben!!!