Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Doppelt vorkommende Datensätze bei beliebig vielen Spalten


Aufgabe
Wenn Doppelte Datensätze bezogen auf mehrere Spalten gesucht und gekennzeichnet werden sollen, können die einzelnen Spalten mit & verkettet werden (siehe Formel Nr. 80).

Wenn es sehr viele Spalten sind, wird das natürlich umständlich. Eine allgemein gültige Formel für beliebig viele Spalten soll gefunden werden.

       A               B               C               D               E               F               G               H       
1 Doppelt  
2  
3             Doppelt  
4              
5             Doppelt  
6      
7    
8 Doppelt  
9              
10      

Lösung
Listenbereich geht von A1 bis G100

in H1 steht
{=WENN(MAX(WENN(ZEILE($1:$100)=ZEILE();1;MMULT(($A$1:$G$100=A1:G1)*1;WENN(ZEILE($1:$7);1))))=7;"Doppelt";"")}

Formel bis H100 kopieren.

Bei 100 Spalten würde man in CW1 schreiben:
{=WENN(MAX(WENN(ZEILE($1:$100)=ZEILE();1;MMULT(($A$1:$CV$100=A1:CV1)*1;WENN(ZEILE($1:$100);1))))=100;"Doppelt";"")}

Sollen nur die Duplikate markiert werden, also nicht die Originale, dann:

{=WENN(MAX(WENN(ZEILE($1:$100)>=ZEILE();1;MMULT(($A$1:$CV$100=A1:CV1)*1;WENN(ZEILE($1:$100);1))))=100;"Duplikat";"")}